Creating ePortfolios with Dreamweaver MX 2004

ITS Technology & Learning Services
Dr. Luanne Fose
Revised September 29, 2005
# Table of Contents

LEARNING THE BASICS OF DREAMWEAVER MX 2004 ................................................................. 2  
GETTING FAMILIAR WITH THE LAYOUT .............................................................................. 2  
THE IMPORTANCE OF SITE MANAGEMENT ........................................................................ 8  
MANAGING PANELS AND PANEL GROUPS ........................................................................ 10  
IMPLEMENTING CAL POLY WEB PAGE TEMPLATES .............................................................. 12  
SETTING PREFERENCES FOR WEB ACCESSIBILITY .............................................................. 13  
A SHORT LESSON ON HTML CODE ..................................................................................... 14  
SETTING THE PAGE PROPERTIES ....................................................................................... 15  
WORKING WITH THE EPORTFOLIO TEMPLATE ................................................................. 19  
CREATING RELATIVE LINKS FOR NAVIGATION BAR ........................................................... 21  
ADDING A DYNAMIC DATE TO YOUR WEB PAGE ............................................................... 22  
USING OUR INDEX. HTML PAGE AS A TEMPLATE ............................................................... 23  
PREPARING YOUR IMAGES FOR THE WEB WITH ADOBE PHOTOSHOP ................................ 23  
ADDING AN IMAGE TO THE INDEX. HTML PAGE .............................................................. 25  
SPELL CHECK YOUR PAGE ................................................................................................... 26  
PREVIEW THE HTML PAGE IN YOUR BROWSER ................................................................. 26  
COPYING/PASTING TEXT ONTO A WEB PAGE ..................................................................... 27  
EXAMINING THE HTML CODE: .......................................................................................... 28  
RUNNING AN ACCESSIBILITY REPORT ............................................................................... 28  
PLACING YOUR FILES ON A WEB SERVER ......................................................................... 31  
PC (WINDOWS) USERS  RUNNING TELNET WITH “RUN” COMMAND .................................. 32  
PC (WINDOWS) USERS USING QVT/TERM TO ACCESS POLYLOG1 ................................... 33  
MAC USERS (OS 9) USING BETTER TELNET TO ACCESS POLYLOG1 ................................. 33  
MAC USERS (OS X) ............................................................................................................... 33  
USING TN3270 3.1.1 FOR OS X ............................................................................................ 33  
LOGGING IN & CONFIGURING WEBSETUP ........................................................................ 34  
VIEWING YOUR WEB SITE ON THE WEB .......................................................................... 38
Learning the Basics of Dreamweaver MX 2004

Dreamweaver MX 2004 is one of the most powerful and popular HTML editing software programs on the market today. Creating a web page and managing your web site with Dreamweaver is much easier than you might imagine. This workshop will cover the basics you need to know to get started with an overview of the basic Dreamweaver features and tools:

Getting Familiar with the Layout of Dreamweaver MX 2004

The Importance of Site Management: Defining a Site

Downloading and Implementing Cal Poly Templates to Create Web Pages

Setting Preferences for Web Accessibility (Making Your Pages Section 508 Compliant)

Adding Keywords and Descriptions to Your Pages to Assist Search Engine Spiders

Working with the Eportfolio Template

Creating Relative, Absolute, and Email Hyperlinks

Creating New Text Content or Importing Existing Text from Microsoft Word

Adding a “Dynamic Date” to Automatically Update Every Time You Change a Page

Inserting Images (Including Editing Images in Adobe Photoshop)

Running an Accessibility Report in Dreamweaver

Uploading Your Files to a Cal Poly Server for Availability on the World Wide Web

Getting Familiar with the Layout

THE WORKSPACE:

Let’s open Dreamweaver and get started! From the Start menu, select Programs>Applications>Keyserver Applications> Macromedia Dreamweaver MX 2004.

When you open Dreamweaver MX 2004 the very first time on a PC, a dialog box will appear asking which environment you wish to work in (Figure 1): Designer workspace or Coder workspace. (Note: Mac users are NOT offered a choice of workspace; the workspace defaults to Designer workspace). The first layout option offered on the PC, Designer workspace, allows you to open several documents within the same window and Dreamweaver’s panels are organized into groups and docked on the right side of the Dreamweaver window. Coder workspace is a variation on the Designer workspace with the panels docked on the left side of the Dreamweaver window. When you first open documents in the Coder workspace, you are presented with the code of the document instead of the view that reflects what the page will look like when viewed with a browser (i.e., Designer workspace). For the purpose of this tutorial, select the Designer workspace radio button and click OK. If in the future you become more comfortable with working with code and prefer viewing the HTML code for your document as the first view of a page, you may change this setting by going to Edit>Preferences (Ctrl+U) and selecting the General category. Within the General category, click on the Change Workspace... button and the dialog box will appear again, allowing you to change your workspace choice. (Note: On a Mac, Preferences are found under the Dreamweaver MX 2004 menu at the top left of the screen.)
After you have chosen your workspace configuration, Dreamweaver MX 2004 will open with the Start Page showing (Figure 2). If you're new to Dreamweaver, the Start Page can be useful since it gives you quick access to tutorials and a tour of the key features. It also gives you immediate access to more recently opened files and one-click creation for static or dynamic pages.

If the Start Page seems to be in your way and you don't want it opening every time you open Dreamweaver, you can turn it off by going to Edit>Preferences>General and turning off the checkmark under Document options: where it says “Show start page” and click OK.

On the Start Page, click on the HTML link under where it says Create New. This will open a new HTML page to work with. When Dreamweaver MX 2004 opens a new HTML document, it...
opens with the main window called the **Document Window** (Figure 3) and several panels and palettes appear as well. If you have opened Dreamweaver before, the panels will be placed exactly where they were the last time you quit the program. Panels and palettes that have been closed previously may be accessed from the **Windows** menu within Dreamweaver.

**THE DOCUMENT WINDOW:**

The **Document Window** is the main center of activity in Dreamweaver. Since Dreamweaver considers itself to be a **WYSIWYG (What You See Is What You Get)** HTML tool, the Document Window will give you a clear idea of what you can expect to see in the web browser window when you are done (although not exactly).

![Figure 3: Document Window]
Let’s Examine the Document Window:

1. The Title Bar displays the filename and the title of the current web page.
2. The Body of the HTML document is displayed in the main viewing area of the Document window.
3. The Status Bar at the bottom of the Document Window indicates three important properties of the document:
4. The Tag Selector: This displays all the HTML tags that apply to the current selection.
5. The Window Size indicator: This displays the current size of the Document Window (e.g., 760 X 420). The Window Size is an important parameter for determining how the final web page will be displayed on different sized monitors. The numbers in the Window Size indicator will change if you resize the Document Window so you should NEVER change the size of the window by dragging on the lower right-hand corner as you would in other applications. Instead, you should use the Window Size indicator to set a pre-set window size by clicking on the arrow, which will display a pop-up window of choices. 760 X 420 (800 X 600) maximized is a good compromise to meet the needs of both large and small monitors of your intended audience. (Note: You will NOT be able to make a choice from the Window Size indicator if your page has been maximized. If the choices are greyed out in the Window Size indicator, click on the Restore icon in the upper right of your HTML page and then try again.)
6. The Download Status area displays the total size (in kilobytes) of the current page and the amount of time it would take to download on a 56k modem. If you want to see how long it would take to download at a different speed, you can go to Edit>Preferences and select the Status Bar category (Figure 4) and from the pull-down menu next to Connection speed, select a different speed (e.g., 1500 Kilobits per second). For the purpose of this tutorial, leave the connection speed set for 56k.

Figure 4: Status Bar Preferences
THE PROPERTIES INSPECTOR:

The two most important properties to have turned on are the Properties Inspector (Figure 5) and the Insert Bar. From the Window menu, make sure there are checkmarks next to these two items.

![Figure 5: The Properties Inspector](image)

The Properties Inspector is context-sensitive. This means that it will constantly change its appearance depending upon what type of element has been selected in the Document Window. The Properties Inspector controls many important settings, including settings for Text, Tables, Alignment, Images, and Media and you will spend a great deal of time using it to format your pages.

THE INSERT BAR:

The Insert Bar has been slightly changed in Dreamweaver MX 2004. It now displays a pull-down menu of choices rather than using tabs as it did in Dreamweaver MX. The Common menu in the Insert bar allows you to insert the most commonly used objects and is the default menu option. To select other options, click on the pull-down menu next to Common and choose from Layout, Forms, Text, HTML, Application, Flash elements, and Favorites.

![Figure 6: Insert Bar with Common Menu in Dreamweaver MX 2004](image)

If you prefer, you can change the Insert Bar to display the tab views as it did in Dreamweaver MX. To change to tab view, select Show as Tabs from the Common pull-down menu. If you change your mind and want to return to the pull-down menu appearance default, right-click on the area where the tab views appear and select Show as Menu.

As you move your mouse over the various icons in the Insert Bar, Dreamweaver will tell you the name of the tool.
ICONS RESIDING IN THE COMMON MENU:

**Hyperlink Link:** Insert hypertext links at the insertion point, or immediately following the current selection.

**Email Link:** Inserts an email link. This tool is especially useful to have someone contacted on your web page.

**Named Anchor:** This tool places a named anchor at the insertion point. Anchors are great for navigational purposes since it lets you link (jump) to a specific point on a page instead of requiring that someone scroll down to get there.

**Table:** This tool places a table at the insertion point and brings up a dialog box asking you for specific details.

**Image:** This icon is different than in Dreamweaver MX since it has an arrow with a submenu attached to it. Within the submenu you can select from the following:

- **Image:** Inserts an image at the insertion point. A dialog box appears so that you can select an image file.
- **Image Placeholder:** Inserts an image placeholder at the insertion point. This is great for when you don’t have the image ready yet but want to reserve a place for it in your layout. A dialog box allows you to specify a name and dimensions for the placeholder where you can later place your image.
- **Rollover Image:** This choice prompts you to specify two image files (an “on” and an “off” image) that are used to define a rollover. A rollover is an image that changes when the mouse moves across it.
- **Fireworks HTML:** This choice places an HTML file produced by Fireworks at the insertion point.
- **Navigation Bar:** Inserts a set of images to be used for navigating through a web site. The Navigation Bar usually consists of four images for each button that represent a different user action of the button such as Up, Over, Down, and Over While Down.
- **Media:** This option contains buttons for inserting animated or interactive media objects such as Flash, Flash Buttons, Flash Text, Java applets, Parameters, ActiveX objects, and Plugins (e.g., QuickTime movies).
- **Date:** This option places the current date at the insertion point. A dialog box appears in which you can specify a format for the date and indicate whether Dreamweaver should update the date automatically every time you save the file making it dynamic.
- **Comment:** This option places a comment in the HTML code at the insertion point. If you’re in Design view, a dialog box appears where you can enter text for the comment. To view the comment, look at the page in Split or Code view. Comments are an excellent way to keep track of special things you did in the code that you might not remember when you are viewing the code at a later date. Comments do not show up in the browser or Design view of the document.
Templates: This option allows you to insert editable, optional, and repeating regions in template files that you wish to use over and over.

Tag Chooser: This option allows you to choose a tag to insert, from a hierarchical tree of categorized tags.

Other tabs besides Common in the Insert Bar include Layout, Forms, Text, HTML, Application, Flash Elements, and Favorites. Below are short explanations of these other menu choices:

The Layout menu allows you to insert tables and layers, and lets you choose between two views of tables: Standard (default) view and Layout view.

The Forms menu contains buttons for creating forms and inserting form elements.

The Text menu allows you to insert a variety of text- and list-formatting tags, such as b, em, p, h1, and ul.

The HTML menu allows you to insert a Horizontal Rule or add Head tags such as Meta, Keywords, or Descriptions.

The Application menu allows you to insert dynamic elements such as recordsets, repeated regions, and record insertion and update forms.

The Flash Elements menu allows you to work with Flash movies that can be configured in Dreamweaver. After a Flash element is added, its attributes are available in the Tag Inspector for personalization. Dreamweaver MX 2004 ships with one Flash element called Image Viewer which enables designers to easily create slide shows with a variety of animated transitions.

The Favorites menu allows you to configure your own Insert Bar according to your own specifications. You are presented with the Customize Favorite Objects dialog box from which you can choose the objects you wish to include in your own favorites Insert Bar. Objects can be grouped through the use of a dotted-line separator.

The Importance of Site Management

File management is one of the biggest challenges of building a web site. Web sites require the creation of many documents and their properties all at once due to numerous text and image files. Organization, folder structure, and consistent naming conventions of all the pages and graphics are a very important part of building a web site.

In addition, the fact that most people build web sites from their hard drive and then upload the files to a web server when they finish just compounds the organizational problem! For example, if you created content in folders on your hard drive and called the folders “HTML” and “Images,” you would need to replicate this EXACT folder structure when you uploaded the files to your web server or the links to your files would be broken.

Dreamweaver has created a site-management scheme that helps alleviate this problem by requiring that you keep all your files within one main “root” folder so that you can easily
duplicate the folder structure that is on your hard drive when you upload the folders to a web server. A root folder is not any different from any other kind of folder on your hard drive except that you have specified to Dreamweaver that all your web development will take place within that folder. The advantage of this system is that if you decide at a later time to change the folder hierarchy of your site by adding a folder or changing a folder name, these changes can be made easily. If you were to hand-code the pages instead and decided to make changes mid-stream, it would be quite a painful process to check all the links and file names (I know first hand... I did it once!) Dreamweaver can make this process painless as long as you choose to work within its site-management scheme.

**DEFINING A SITE – THE KEY TO SUCCESS**

You will be working with a root folder containing HTML and image files called "class_eportfolio" that has already been placed in the My Documents folder on the Desktop of your computer in the Training lab. The path to this folder is My Documents>Eportfolio_Workshop-LFose>class_eportfolio.

1. From the Site menu at the top of Dreamweaver, select Manage Sites... Dreamweaver will open the Manage Sites window. Click on the New button and from the submenu, select Site. Dreamweaver defaults to opening the Site Definition window with the Basic tab selected. The Basic tab will take you through a series of questions (a sort of wizard) to help you create the settings for your site definition. For the purposes of this tutorial, click on the Advanced tab to bypass this.

2. With the Advanced tab selected, make sure that Local Info is highlighted in the Category area on the left of this window. For the Site Name:, type "class_eportfolio" (Note: For Local Info this is an internal naming convention so you can use any kind of name you wish without worrying about whether or not to use spaces or capitalization)

3. Click on the small yellow folder icon to the right of the Local Root Folder: text box. Navigate to the class_eportfolio folder that is in the My Documents folder on the Desktop of your computer. (Remember the exact path is My Documents>Eportfolio_Workshop-LFose>class_eportfolio) Click on the class_eportfolio folder once and click the Open button; then click on the Select button. Note: DO NOT highlight the images folder before clicking on Select. (Mac users: Simply click on the folder once and click Choose)

4. Click in the checkbox next to Refresh Local File List Automatically. Also click on the checkbox next to Cache: Enable Cache. This will increase the speed with which Dreamweaver performs its link-management features.

5. Click on the small yellow folder icon next to Default Images Folder: and take the same path as before but this time add the images folder to the entire path (i.e., My Documents>Eportfolio_Workshop-LFose>class_eportfolio>images) Click on the images folder once and click the Open button; then click on the Select button.

6. Click OK at the bottom of the dialog box to save your site definition and when the Manage Sites dialog box appears, click Done.

7. Congratulations! You have just set up your first Dreamweaver site! When you later open the Files Panel Group, your setup should look something like the illustration in Figure 7 below.
Managing Panels and Panel Groups

Dreamweaver MX 2004 has retained the earlier layout of Dreamweaver MX, which introduced the use of panel groups and panel tabs (Figure 8). Each panel group can be expanded or collapsed, and can be docked or undocked with other panel groups. If you wish to customize your panel groups, it will make it easier to access the panels you need without cluttering your workspace. Panels within a panel group appear as tabs.

![Panel Groups](image)

Figure 8: Panel Groups

To expand or collapse a panel group, do one of the following:

Click on the expander arrow on the left side of the panel group’s title bar

**OR**

Click on the panel group’s title.
Let's look at a few of the more important Panel Groups and Panels:

**THE FILES PANEL:**

You will probably find that you access this the Files Panel Group the most. The Files Panel Group allows you to define a site, manage the local files in your site, upload and download files from a remote site, and browse the files on your local disk outside of your site. With the Files Panel you can make a local site on your hard drive that’s just like the directory structure site on your web server so that everything exports to the server smoothly. If you don't see the Files Panel, go to Windows>Files (F8).

**THE ASSETS PANEL:**

The Assets Panel tab (within the Files Panel Group) displays the elements, such as images or movie files that you are using in building your page or site. You can obtain assets from various sources. For example, you might create assets in an application such as Macromedia Fireworks, Adobe Photoshop, or Macromedia Flash, receive them from a co-worker or client, copy them from a clip-art CD, or download an image from a graphics web site. You can use the Assets Panel in two ways: as an easily accessible list of the assets in your site or as a way to organize the assets that you use most frequently by using the Favorites list. The Assets Panel tab automatically puts your site’s assets in the list when the Site radio button is selected. You may add whatever assets you wish to the Favorites list for easy access by highlighting the assets you wish to add and then clicking on the Add to Favorites button at the bottom right-corner of this panel. You can view the assets in your Favorites List by clicking on the radio button next to Favorites.

**THE HISTORY PANEL:**

You may want to add the History Panel Group to the list of panels on the right of the screen in order to access its “undo” features. To add the History Panel Group, select Window>History (Shift+F10). The History Panel will show you a list of the steps you've performed in the active document since you created or opened that document, up to a specified maximum number of steps. (Note: The History panel doesn’t show steps you’ve performed in other frames, in other Document Windows, or in the Files Panel.) It allows you to undo one or more steps; it also allows you to replay steps and to create new commands to automate repetitive tasks. The slider in the History Panel initially points to the last step that you performed. One of the great things about the History Panel is that even after you have saved the document before viewing it in your browser, you can undo your steps in the History Panel as long as you don’t close the document. Once you close the document, the steps in the History Panel will be gone.

To undo the last step in the History Panel:

Drag the History Panel slider up one step in the list. This has the same effect as choosing Edit > Undo. The undone step will turn gray.

To undo multiple steps at once, do one of the following:

Drag the slider to point to any step

OR

Click to the left of a step along the path of the slider; the slider scrolls automatically to that step, undoing steps as it scrolls.
As with undoing a single step, if you undo a series of steps and then do something new in the
document, you can no longer redo the undone steps; they will disappear from the History Panel.

To change the number of steps that the History panel retains and shows:
Choose Edit > Preferences > General.
Enter a number for Maximum Number of History Steps (default is 50).

The default value should be sufficient for most users' needs. Be aware that the higher the
number, the more memory the History Panel requires. This can greatly affect computer
processing performance and significantly slow down your computer. When the History Panel
reaches this maximum number of steps that have been set in Preferences, the earliest steps are
discarded from the panel.

---

Implementing Cal Poly Web Page Templates

The Cal Poly Web Authoring Resource Center (WARC) provides developers of Cal Poly official
web sites with the information and tools necessary to plan and build a site that meets basic
requirements for university identity, web accessibility, usability, and aesthetics. In addition, the
WARC provides valuable information on how best to maintain web sites for currency and
efficiency. Check out the WARC web site by opening a browser (Internet Explorer or Netscape)
and navigating to the following URL: http://www.calpoly.edu/warc/

On the WARC website, you will find a section allowing you to download university templates The
path to the templates page is University ID > Templates from the above URL or directly
http://www.calpoly.edu/warc/universityid/templates.html By using the university
templates, you are establishing your web pages as an "official" part of the Cal Poly University
web site. The templates have been designed to be consistent with and complimentary to the
recent redesign of the Cal Poly home page and its top-tier subsections (i.e., Students, Faculty &
Staff, Prospective Students, etc.). The templates conform to the university’s “Minimum Page
Requirements” for web pages and were specifically designed for easy navigation and eye-
pleasing appearance after surveys and meetings with campus focus groups. They have also
been designed with usability and web accessibility in mind. You can easily "personalize" them
to reflect your department or group and each layout has been created to provide substantial
"free" space for extensive customization within the body of each template. We believe that it's
important that Cal Poly web pages reflect standards of quality and professionalism appropriate
to showcase the university as what it is -- one of the nation’s best -- and implementing the
templates will assist you in this task.

LET’S DOWNLOAD THE TEMPLATES AND PLACE THEM WITHIN Dreamweaver:

1. Go to http://www.calpoly.edu/warc/universityid/templates.html
2. Click on the “Download Now” link at the top of this page. This will take you to
http://www.calpoly.edu/warc/universityid/templates/download.html
3. Under the section labeled “Cal Poly Template download,” navigate to the area that
applies to your operating system (PC or Mac) and click on the appropriate link.
4. Since we are using PCs in this tutorial, click on “cp_template_v1.1.zip - (PC)” to
download it to the Desktop of your computer.
5. When the File Download dialog box appears (Figure 9), click on the Save button.
6. When the **Save As** dialog box appears, save the file to your Desktop or you’re **My Documents** folder. A .zip file will be placed there. Use a utility such as Stuffit Expander, WinZip, or Power Archiver to unzip the file. (Note: Mac users will need to use Stuffit Expander to unstuff the .sit file). If you are using a Cal Poly license for the Power Archiver utility, double-click on the file and when the Power Archiver new window pops up, choose **Action > Extract** and click the **Extract** button.

7. You should now have a folder called **cp_template** unzipped on your Desktop or **My Documents** folder.

8. Right-click on the **cp_template_v1.1.zip** and select **Delete** to delete the zipped folder.

9. Double-click on the **cp_template folder** to open it. Right-click on the **cp_template.html** file and select **Copy** from the menu. Navigate to your root folder for your website. Right-click and paste the **cp_template.html** file into that location.

10. Now move the images from the **cp_template folder** to our **images folder within your root folder**. Navigate to the **cp_template>images** folder and select everything (Ctrl-A or Shift-Click) in this images folder (including the additional image folders of **footer**, **header**, **menubreadcrum**) and then right-click your mouse and select **Copy**.

11. Navigate to your **rootfolder>images folder** and open the folder. Right-click in the folder with your mouse and select **Paste** to move the necessary Cal Poly images to this folder.

12. Now when you look in your Files Panel Group within Dreamweaver, you should see the **cp_template.html** file as well as the additional images and images folders within the **root** folder for your website.

---

**Setting Preferences for Web Accessibility**

Similar to Dreamweaver MX of the past, Dreamweaver MX 2004 allows you to set your preferences so that you will be reminded to follow the 508 federal accessibility guidelines as you insert images, tables, forms, and other media into your web page.

To Turn on Accessibility Preferences:

1. Go to the **Edit >Preferences (Ctrl-U)**.
2. In the Category column at the left side of this dialog box, click on Accessibility.

3. Click all the checkmarks under Show Attributes when Inserting: (i.e., Form Objects, Frames, Media, Images). (Note: Unlike Dreamweaver MX, you will no longer turn on accessibility options for Tables; these options have been improved and automatically incorporated into the Tables dialog box now.)

4. Make sure that Offscreen Rendering (Disable when using Screen Readers) is also selected.

5. Click OK.

6. Now when you insert an image, form objects, or media, Dreamweaver will bring up the appropriate dialog boxes to remind you to insert the proper Alt tags, etc., that are needed to make your web pages accessible to everyone.

---

**A Short Lesson on HTML Code**

An HTML page is a set of instructions (tags) suggesting to your browser how to display the enclosed text and images. The browser knows what kind of page it is handling based on the tag that opens the page (e.g., `<html>`) and the tag that closes the page (e.g., `</html>`). The great majority of HTML tags come in pairs, in which the closing tag always has a forward slash before the keyword (e.g., `<p>` and `</p>`). A few important tags may be represented by a single element tag such as the image tag `<img>`.

An HTML page is divided into two primary sections: the `<head>` and the `<body>`. Information relating to the entire document goes in the `<head>` section: the title, description, keywords, and any language subroutines called from within the `<body>`. The content of the web page is found in the `<body>` section. All the text, graphics, embedded animations, Java applets, and other elements of the page are found between the opening `<body>` and closing `<body>` tags.

Summary information about the content of a page is conveyed through `<head>` tags that reside within the `<head>` section of your web page. Two important `<head>` tags you might want to be aware of are Keyword objects and Description objects. By inserting keywords on your web page, you can assist search engines spiders in categorizing your page and have a huge impact on the accessibility of your page. Although the title of your web page that fits into the browser
title bar also affects how your page is categorized with search engine spiders, the Keyword and Description tags have an unlimited amount of room, allowing you to expound on the content of your web page. However, avoid the temptation to stuff these head tags repeatedly with the same word. The search engines are engineered to reject too many instances of the same words and your description will not get the attention it deserves. The content that you place in your Description box will be the description that will appear next to your link on the search engine’s page of findings. For this box, you should use sentences that clearly describe what your web page is about.

**TO ADD KEYWORDS TO YOUR WEB PAGE:**

1. Open a web page within Dreamweaver (for the purpose of this tutorial, double-click on the page called `class_eportfolio_template.html` in the Files Panel Group to open it.)
2. Select Insert > HTML > Head Tags > Keywords
3. When the Keywords dialog box appears, type appropriate keywords for your webpage in lowercase with commas between them (e.g., biology eportfolio, teaching vision, BIO 425 class projects, california polytechnic state university)
4. Click OK.
5. If you click on the Code button, you can see the keywords listed in the head section of the HTML code as `<meta name="keywords" content="biology eportfolio, teaching vision, BIO 425 class projects, california polytechnic state university">` This is the code the search engine spiders need to categorize your page and find it when someone searches for your page.

**TO ADD A DESCRIPTION TO YOUR WEB PAGE:**

1. With the same class_eportfolio_template page open, select Insert > HTML > Head Tags > Description.
2. When the Description dialog box appears, type a description of your web page in sentence form with proper capitalization and punctuation.
3. Click OK to close the dialog box.
4. If you click on the Code button, you can see the description listed in the head section of the HTML code as something like this: `<meta name="description" content="This is the home page for [insert name]'s eportfolio. Topics covered include a professional profile, education, resume, teaching vision, classes & projects, publications, presentations, and helpful links.">` This is the text that will appear as the description of your web page when a search engine lists it.

---

**Setting the Page Properties**

When you first open a new page in Dreamweaver, your default web page is untitled, with no background image and only a plain, white background. You can change any of these properties (and more) with Dreamweaver’s Page Properties dialog box. In Dreamweaver MX, the Page Properties were set to use HTML tags to set up the text and link colors, the background color or background image, and the page title. These value were automatically placed within the `<body>` tag. Dreamweaver MX 2004 promotes the use of Cascading Style Sheets (CSS), which is quickly becoming the standard in the industry. CSS uses internal or external “style sheets” which affect the properties settings of an entire page (internal) or an entire web site (external).
For the purpose of this tutorial, we are going to create an internal CSS within Dreamweaver and then export it and attach it to all our pages in our web site in order to create an external CSS that effects all our pages. Using CSS is the most efficient method to work with web sites. Once you use it, you will see why so many people are turning to this method of managing the style of their web page content.

1. Before we get started setting the Page Properties, let’s make that sure that the default for using CSS hasn’t been turned off. Go to Edit > Preferences > General and make sure that under Editing options: there is a checkmark next to “Use CSS instead of HTML tags” and then click OK. (Note: If in the future, you wish to use HTML tags instead of CSS, you would want to turn this option off.)

2. With the class_eportfolio_template.html file still open, choose Modify>Page Properties (Ctrl-J) or click on the Page Properties button that is in the Properties Inspector (Note: This button is new to Dreamweaver MX 2004). The following dialog box will appear:

![Figure 11: Page Properties with CSS Turned On](image)

3. With Appearance selected in the Category list on the left of this dialog box, click on the pull-down arrow next to where it says Page font: and select the font list of Verdana, Arial Helvetica, sans-serif. This will now be the font list that all of your text will default to unless you change it manually. Notice that in designing web pages you don’t select just one font but rather you provide Dreamweaver with a “font list.” The font list has your first-choice font listed first; if the viewer of your web page doesn’t have that font, it will load the next font choice that you have provided in your font list. If you wish to make your own font list, click on the pull-down menu next to Page font: and select Edit Font List...
4. When the Edit Font List dialog box appears (Figure 12), find **Tahoma** in the Available Fonts: box and click on the left arrow to add it to the Chosen Fonts: box. Continue to do this adding **Verdana**, **Arial**, and **sans-serif**. You will see them added in the Font List: box at the top of this dialog box. Click OK to confirm this font list. Now back in the Page Properties dialog box, if you select the pull-down menu next to **Page font:** you will see your new font list of **Tahoma, Verdana, Arial, and sans-serif** added to the list. For the purpose of this tutorial, keep your font choice as **Verdana, Arial, Helvetica**.

5. By using CSS, we can select our font size to be displayed in a variety of ways (i.e., pixels, points, inches, centimeters, millimeters, picas, etc.). Next to the **Size:** text box, select **12** from the pull-down arrows and select **pixels** from the pull-down menu next to it. (Note: You can also type in the number of the size if you prefer.)

6. Next to **Text color:** click on the little color palette box and select a black of **#000000** to be the default for your pages or simply type the hexadecimal code of **#000000** in the text box.

7. Type the hexadecimal number **#A1B39C** in the text box next to **Background color.** This color has been selected as the default background color for the Cal Poly template. If you wanted to change this color, you could click on the color palette next to the word **Background color:** and select a color from the web-safe color palette. (We will discuss hexadecimal numbers and what they mean in terms of web-safe colors later.)

8. The **Background Image** area allows you to browse for a different background image if you wish to use one that you have created previously with a program such as Adobe Photoshop or Macromedia Fireworks. We won’t be using a background image in this tutorial so you can just ignore it for now.

9. Set all the **Margins** to **0 pixels**.

10. Now in the **Category** list of this dialog box, click on **Links** so that we can set the default link properties.

11. Where it says **Link font:** let it stay at the default of **(Same as page font)**.

12. For the **Size:** leave it alone (if you put 12 pixels here it will actually cause problems).

13. Set the **Link color:** at **#003300** (This is a dark green that matches some of the other images on the Cal Poly template).

14. Set the **Visited links:** to be a blue color (hexadecimal **#243A97**). This will cause the links to from green to blue if someone has already visited a particular link.
15. Set the **Rollover link:** to be a gold color (hexidecimal #CC9900) This will cause the link to change to gold when the viewer places the mouse over the link.

16. Set the **Active link:** to be the same green as the link color: #003300. This is the color that the link changes to briefly when the user selects a link. In this case, there would be no change; it would remain green.

17. Next to the Underline style: select Always underline.

18. For now, we are going to skip working with the **Headings.** But this is where you could set the font for all headings, the sizes, bold, italic, and color of the various headings (tags <h1> - <h6>) if you desired.

19. Now in the **Category** list of this dialog box, select **Title/Encoding.**

20. In the text box next to **Title:** type “[Insert name] – eportfolio” This will appear as the title for this page in the web browser. **Note:** You can also change a document’s title in the Document Window by clicking in the **Title** field and pressing **Enter**.

21. In the text box next to **Encoding**, make sure that it says **Western (European)** which is the default.

22. Click on the **Apply** button and then click **OK** to close the **Page Properties** dialog box.

23. Now, if you click on the **Design Panel Group** and select the **CSS Styles** tab, you will see that several CSS styles have been set for you. You can either edit them from this area or re-open **Modify > Page Properties** to edit them.

**A WORD ABOUT WEB–SAF E COLORS:**

What is a web–safe or browser–safe color? Web–safe colors are the 216 colors supported by browsers across different platforms (Mac and Windows). If you use the browser–safe colors inside the Page Properties setting, you reduce the risk of having your colors look differently than you intended them to when people view your web pages on different platforms and browsers. In HTML, colors are expressed either as hexadecimal values (e.g., #FF0000) or as color names (e.g., red, black, blue, etc.). All the colors in the color palettes used in Dreamweaver are web–safe and in fact, any hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF represents a web–safe color. You can use the eyedropper to select from these colors in the palette. Go to [http://www.lynda.com/hexh.html](http://www.lynda.com/hexh.html) to view a web–safe colors chart with hexadecimal and RGB references.

**SAVING YOUR WORK:**

Before we make any more changes to the page, let’s save the file with a new name – we are going to call it **index.html**. A web page with this name has special significance. Most web servers recognize the index.html page as the default home page of a site. If you type the URL [http://www.calpoly.edu](http://www.calpoly.edu), for example, what you will really see is the index.html page for the Cal Poly web site, even though you did not type the URL that way. The web server knows to open the index.html file automatically without requiring that the full URL be typed in which would actually be [http://www.calpoly.edu/index.html](http://www.calpoly.edu/index.html). This routine is a standard on all UNIX–based servers and many web administrators (even though they use Windows–based servers), change their settings to incorporate index.html as the default home page. Therefore, if you name the opening page of your web site with the file name index.html, the web server will automatically open this file and you will save people from having to type a longer URL.

You should periodically save your work as you are working on a web page to make sure that nothing happens to it (e.g., power outage, software or hardware crash, etc.). Save your work right now by selecting **Save As...** from the **File** menu and let’s rename the file and call it **index.html**.
index.html. Check the location to make sure it is being saved to the proper folder (i.e., My Documents>Eportfolio_Workshop–LFose>class_eportfolio) and then click on the Save button. In the future when you wish to save the file, you can always just select Save from the File menu (or Ctrl–S) since you have named the file and selected a location; however, to be sure that it is truly being saved, using the Save As… command is a safer way to save. The next time you use the Save As… command and click the Save button, Dreamweaver will ask if you want to overwrite the file; when this happens, click Yes.

---

**Working with the EPortfolio Template**

Let’s change some of the text on the Eportfolio template that we have saved as index.html:

1. Your index.html page should be open since you just saved it with that name, but if it isn’t, double-click on index.html in the Files Panel Group.
2. Highlight the text for “Name” at the top–right area of the web page and press the Backspace key to delete it.
3. Type “[Your Name]”.
4. In the bottom–right area of the page, type the name of your college where it says “College of” and type the name of department where it says “Department of.”
5. Change the phone number from 805.756.XXXX to whatever contact you desire.
6. Click on the text where it says name@calpoly.edu and change it to say [your name]@calpoly.edu
7. Now, let’s change the email link itself. Highlight the entire link and then look at the address given in the Properties Inspector (Figure 13) where it says: Link.
8. Unlike other links, an email link always has the words mailto: in front of the actual email address. Change the link to say: mailto:[your name]@calpoly.edu

![Figure 13: Properties Inspector with Email Link](image)

9. Next, while the text is still highlighted, you can click on the Bold (B) button in the Properties Inspector to make the email text stand out a bit better.
10. The font color is already chosen because of the choices that were made in the Page Properties dialog box earlier. However, you can change the color of individual text selections by highlighting the text and clicking on the Text Color Palette next to the Size: box. A color palette will appear with web–safe colors to select from. Notice also that if you drag your mouse outside of the color palette, the pointer changes to an eyedropper and a hexadecimal number appears in the color palette title bar. You can select colors from images to have the image colors correspond more closely to the text colors in your site. Although we are using black as the text color for our site, let’s change the text for Last Update to red (hexidecimal #FF0000) so that you can see how
easily text color can be changed from the default. Highlight the words Late Update and click on the Color Palette and select the red color (i.e., hexadecimal #FF0000) to change the text color for these words to red.

Figure 14: Web Safe Color Palette

RESIZING THE DOCUMENT WINDOW:

The Document Window status bar displays the window’s current dimensions in pixels. If you click this window size, Dreamweaver displays the Window Size pop-up menu, which lets you set the window size to fit any of several common monitor sizes. To design a page that looks its best at a specific size, you can adjust the Document Window to any of the predetermined sizes, edit those predetermined sizes, or create new sizes.

Let’s choose a predetermined size for the Document Window:

1. Click on the arrow on the Windows pop-up menu at the bottom of the Document Window to reveal the predetermined choices (Figure 15). For our index.html document, make sure that 760 X 420 is selected, which is the optimum size for an 800 X 600 monitor – the normal size of the general population’s monitor these days. The window size given reflects the inside dimensions of the browser window, without borders; the monitor size is listed in parentheses.

2. Note: If Dreamweaver will not allow you to select a different size in the Windows pop-up menu (i.e., the selections are greyed out), click on the Restore (i.e., Maximize) button for that particular page and then you should be able to select the 760 X 420 size.

Figure 15: Set Window Size
EDITING THE NAVIGATION BAR:

The Cal Poly web page template has a navigation bar on the left side of the page to assist the viewer in navigating to the other pages in the web site. Let’s edit it to reflect our pages:

1. Place the cursor at the end of the text in the navigation bar that says Sample Text 1. Use the Backspace key to delete this text. Type: “Profile” to replace it and then highlight the text and press the Bold button in the Properties Inspector to bold the text.

2. Place the cursor at the end of the text in the navigation bar that says Sample Link 2. Use the Backspace key to delete this text. Type: “Education” to replace it and Bold this text.

3. Place the cursor at the end of the text in the navigation bar that says Sample Link 3. Use the Backspace key to delete this text. Type: “Resume” to replace it and Bold this text.

4. Place the cursor at the end of the text in the navigation bar that says Sample Link 4. Use the Backspace key to delete this text. Type: “Teaching Vision” to replace it and Bold this text.

5. Place the cursor at the end of the text in the navigation bar that says Sample Link 5. Use the Backspace key to delete this text. Type: “Classes & Projects” to replace it and Bold this text.

6. Place the cursor at the end of the text in the navigation bar that says Sample Link 6. Use the Backspace key to delete this text. Type: “Publications” to replace it and Bold this text.

7. Place the cursor at the end of the text in the navigation bar that says Sample Link 7. Use the Backspace key to delete this text. Type: “Presentations” to replace it and Bold this text.

8. Place the cursor at the end of the text in the navigation bar that says Sample Link 8. Use the Backspace key to delete this text. Type: “Links” to replace it and Bold this text.

9. If you need to add or delete rows to this navigation table, place your cursor on one of the rows of the table and select Modify>Table>Insert Row or Modify>Table>Delete Row.

10. Go to the bottom of the index.html page and change the text for the Sample Link 1 through Sample Link 8 to reflect the same navigation: Profile, Education, Resume, Teaching Vision, Classes & Projects, Publications, Presentations, and Links.

Creating Relative Links for Navigation Bar

The ability to link to other pages and sites is what makes the web dynamic. Besides email links, which we have already made, there are two other types of links: relative and absolute. Relative links will take you to another page within your own web site; absolute links will take you to an outside web site on the World Wide Web.
We will start by adding relative links to our navigation bar text:

1. Highlight the text “Profile” in the left navigation bar. Go to the Link box in the Properties Inspector and type “index.html.” This is the name that we are going to save the Home page out as so the Profile section will always occur as a part of the Home page.
2. Continue in this manner, highlighting text in the navigation bar for Education, Resume, Teaching Vision, Classes & Projects, Publications, Presentations, and Links creating the following links respectively: education.html, resume.html, vision.html, projects.html, publications.html, presentations.html, and links.html. (NOTE: DO NOT USE CAPITAL LETTERS OR SPACES TO NAME YOUR WEB PAGES)
3. Create the same links for the navigation of Profile (index.html), Education (education.html), Resume (resume.html), etc. at the bottom of the web page as well.
4. Go to the text at the top of the page where it says “Home Page” and insert your name so it says “[Insert Name] Home Page. Now highlight this text and then go to the Link box in the Properties Inspector and type “index.html”. This will allow the user to always return to your Home page from wherever they might be.

Now we will add an absolute link to a web site on the World Wide Web:

1. Open Internet Explorer and find the Cal Poly web site you wish to have your viewers link to. Type the URL: http://www.calpoly.edu This should take you to the official Cal Poly web site for San Luis Obispo. Highlight the URL so it is completely selected and press Control–C to copy it to the Clipboard. Close Internet Explorer.
2. Return to your index.html page and highlight the text “California Polytechnic State University” in the right bottom part of the page. Place your cursor in the Link box of the Properties Inspector and press Control–V to paste the URL. By using this method of going to the web site first in your browser, you will eliminate the possibility of having a dead link due to a typo or spelling error.
3. If you wish, you could add links, in a similar manner, to your specific College and Department text in the bottom-right corner as well.

Adding a Dynamic Date to Your Web Page

If you add a dynamic date to your web page, it not only allows the viewers to know when the page was last updated, it also updates the date automatically anytime you save the web page.

1. Navigate to the bottom of the page where it says “Last Update” and place your cursor right after the colon of this text (Note: Do not allow for a space in between or the formatting may be destroyed).
2. From the Insert Bar, select the Common tab and then select the Date icon.
3. The Insert Date dialog box will appear (Figure 16). Select the Day, Date and Time Format that you desire and then place a checkmark in the box next to Update Automatically on Save. Click the OK button and a date will be added as you requested. Every time you save the web page, the date will automatically be updated.
Using Our Index.html Page as a Template

Now that we have our index.html almost completed and have the navigation bar and links set, we can save this page out to use as a template for our other web pages.

1. Go to the File menu and select Save As… Save this page as eportfoliotemplate.html.
2. Now go to the File menu and select Save As… again. Now save the page as index.html.
3. Continue to do this seven more times, saving the page differently each time with the names education.html, resume.html, vision.html, classes.html, publications.html, presentations.html, and links.html. You should see these eight pages and the eportfoliotemplate.html page added to your Files Panel Group on the right of the Dreamweaver screen.
4. If you saved the pages with the new names in the order described above, the page you are currently working on has been renamed "links.html". Close this page by going to File > Close.

Preparing Your Images for the Web with Adobe Photoshop

Now we are going to take a short segue in this tutorial to learn how to use Adobe Photoshop to size and crop images. (Thank you, Tonia Malone, for allowing me to use your tutorial here!)

Cropping and Image Size:
When placing an image on a web page your image should be only as large as it needs to be to display correctly on the page. If your image is too large (800 x 600) and you resize it within the Dreamweaver application by dragging its corners, the file size is not reduced, just the visual size of the image. If you reduce the image size in Photoshop to display the correct size on the web page, you can save file space/size and allow the viewer to view the image much quicker.

(For example: An image sized at 800 x 600 could be a 2MB file. If that file is reduced to the size...
needed on the page, e.g., 360 x 413, the file size can be brought down to 436k. This file is easier for someone to view on a web page through their network connection and saves space on the server.

You may also crop an image to remove extraneous content of the image that you may wish to eliminate. If you wish to crop content, it is always best to crop first and then resize the image.

1. Open Photoshop.
2. From the File menu, select Open and navigate to the photo you wish to resize. For the purpose of this tutorial, navigate to My Documents>Class Materials>Eportfolio_Workshop-LFose>class_eportfolio>images and select the image called 01_female_faculty_original.jpg or 03_male_faculty_original.jpg (Do NOT select 02_female_faculty_small.jpg or 04_male_faculty_small.jpg since these are the finished products cropped and resized.)
3. If the image is large, Photoshop may open the image at a smaller percentage such as 25% or 33%. Make sure your image is at 100% size by clicking on the percentage number at the bottom left of the image and changing the value to 100% and then hit Enter to set it at this size.

4. Select the Crop Tool in Photoshop
5. Click and drag the Crop Tool over the image to select the area you wish to KEEP.
6. Select Image > Crop and the image will be cropped.
7. If you feel the color isn’t quite right, try changing the Auto Levels by choosing Image > Adjustments > Auto Levels… Click Edit > Undo if you don’t like the change.
8. Now let’s change the size of the image. From the Image menu, choose Image Size.
9. Set the Resolution to 72 dpi. We recommend that images be saved at 72 dpi for web viewing since a web page is only displayed from a computer monitor at 72 dpi (technically, 96 dpi on PC monitors but most web developers still set dpi at 72.)
10. Make sure the Constrain Proportions box is checked to keep the image size proportional. Change the Document Size Width and Height to the size needed for the web page. For the purpose of this tutorial, change the Width to 200 pixels and the height will adjust proportionally on its own. Click the OK button.

SAVING AS A JPG/GIF:

1. To save a file for the web it is best to use the Save for Web tool in Photoshop. This will allow you to save a jpg or a gif file that is optimized for the web and your viewers.
2. From the File menu in Photoshop, choose Save for Web.
3. Click on the 4-Up Tab. This will allow you to see four images on the page, the original and three other possibilities. There you can make one box a gif and the other a jpg and play with the Quality and Colors (i.e., 8 colors versus 256 colors). Select a box by clicking on it and changing its values. You may not need a 100% JPG; it may look just as good at 60%, which will result in a much smaller file size. Sometimes GIF files can be brought down from 256 colors to 64 colors. Play with the settings and find a good compromise in quality and size for optimal page download time. Note: JPG is generally chosen for photographs (shadows, people, buildings, etc.); GIF is usually chosen for solid colors (logos, flat art, cartoons, drawings, transparent images, etc.)
4. The images for this tutorial, 01_female_faculty_original.jpg or 03_male_faculty_original.jpg, will work well saved as a JPG at 75 Quality.
5. Click the Save button and save it with a new name to your images folder (e.g., female_faculty_small.jpg or male_faculty_small.jpg) Note: Use a new name so you don’t overwrite your original image in case you want it uncropped and at its original size for some other project.

Adding an Image to the Index.html Page

Let’s finish off our home page (index.html) in Dreamweaver by adding an image to it.

1. Double–click on index.html in the Files Panel Group to open it again.
2. Between the colons at the top right of the page, type Profile as the name for this Home page since it will always be connected to the Profile or Home Page linking.
3. Click your mouse below the horizontal bar. This is to place our cursor on the left side of the page in order to add an image there.
4. From the Insert menu, select Image (Control–Alt–I) and then the Select Image Source dialog box will appear. Navigate to your female_faculty_small.jpg or male_faculty_small.jpg image that you cropped with Photoshop and placed in your images folder (i.e., My Documents>Class Materials>Eportfolio_Workshop–LFose>class_eportfolio> images) and click once on the image. You will see an Image Preview to the right in this dialog box. If the image that you previously edited appears, click on the OK button to insert it.
5. Since we set the preferences earlier to remind us to abide by web accessibility rules, the Image Tag Accessibility Attributes dialog box will appear. Where it says Alternate Text:, type “Dr. Ellen Harriet”. This will allow the screen reader to skip the image and continue reading the page while it allows the user to know there was an image of Dr. Ellen Harriet in that location on the web page.

Note: If the image you inserted was primarily for page design (e.g., a header or footer image) and not important for a screen reader to read to a blind or visually-impaired user, you would ignore the Alternate Text: text box and simply click the OK button. Then later in the Properties Inspector, you should select the pop-up menu next to Alt and select <empty>. This will place quotation marks next to the Alt tag in the code (e.g., alt=””), which will not be read by the screen reader. When you run a Dreamweaver Accessibility Report on your web pages (discussed later on in this tutorial) you will find many empty Alt tags, which have been done this way so that they are ignored by a screen reader.
6. If the image of the faculty member isn’t already selected, click on it to select it. This changes the Properties Inspector to show the attributes for the image. If you wanted to create a link on the image, you could simply click on the image and then go to the Link box and type a link. This creates a link to the image when a person clicks on the image.
7. In the text box next to Border: in the Properties Inspector, type 15 and then press Enter. This adds a border of 15 pixels to the image. Note: If a link had been attached to this image, the border color would be set at the color that was set for links in the Page Properties. So for example, if a link was applied to the image the color for the border would appear to be blue in the Dreamweaver Document Window, but when you actually look at this page in the browser, the style is applied with a green border that turns gold (i.e. the selected rollover link color) when the mouse is placed upon it.
8. With the image still selected, choose Right from the pull–down menu next to Align. This will move the image to the right of the page and allow you to wrap text around it to the left.
10. Type whatever text you choose to type to the left of the image.
11. Go to File > Save As... and save your index.html page.

---

**Spell Check Your Page**

You should always spell check your work before you place it on the web.

1. To spell check, go to the Text menu at the top of the Dreamweaver screen and select Check Spelling (Shift+F7). Do a normal spell check throughout the document, clicking the Ignore button for words that you intend to keep as they were typed.

2. Go File > Save As... and save your index.html page.

---

**Preview the HTML Page in Your Browser**

Whenever you are working on a HTML page, you should preview it in your browser to see how it will really look on the web. Preview your Home page by following the steps below:

1. From Dreamweaver’s File menu, select Preview in Browser... and from the submenu, select the browser you wish to view it in (e.g., Internet Explorer or Netscape). Dreamweaver MX 2004 also allows you to preview in a browser by simply clicking on the globe icon at the top of your page and selecting Preview in (name of browser).

2. It will take a few moments as your computer opens the browser you selected and displays a temporary file to view in the browser. It is good practice to always view your web page in both Internet Explorer and Netscape because sometimes the pages will appear slightly different depending upon the browser and previewing them can help you decide upon a compromise on your original web page to get the look you desire in both browsers. This is also where you should test all your links to make sure they work when you are finished with your other web pages.

3. Notice that rollovers have been applied to the links in the navigation bar. Rollovers for the navigation bar are included within the Cal Poly template. For more information on creating rollovers, take the TLS Dreamweaver Rollovers course.

4. Minimize the browser and return to your Home page in Dreamweaver. Make any changes you think you need to make to the page, check it again by previewing it in the browser and then save the page one more time within Dreamweaver.

**CONFIGURING DREAMWEAVER TO USE OTHER BROWSERS:**

1. If you need to configure Dreamweaver to preview in another browser, return to Dreamweaver and select File>Preview in Browser>Edit Browser List... and the Preview in Browser dialog box will open (Figure 17).
2. Click on the “+” sign in this dialog box next to the word **Browsers**:

3. When the **Add Browsers** dialog box appears (Figure 18), type a name for the browser, click the **Browse...** button next to **Application:** to find the browser application on your computer, and click the checkbox next to **Primary Browser** or **Secondary Browser**, depending upon which default you wish it to have.

4. Notice that when you go to **File > Preview in Browser** now, you have the choice of Internet Explorer (F12) or Netscape (Control-F12). You can continue to set up other browsers for previewing in this manner (e.g., Macintosh users may wish to set up a preview choice for the Safari browser, which has become quite popular in the Mac community). F12 and Control-F12 are two commands that are worth memorizing since by using them you can preview your pages without navigating to the **File** menu first or without having to click on the globe icon.

---

**Copying/Pasting Text onto a Web Page**

The best rule of thumb for copying/pasting text from another source (such as a Microsoft Word document) is to strip it of it’s formatting before bringing into Dreamweaver. To do this, follow the instructions below:
1. Open Microsoft Word, go to File > Open… and navigate to the following folder: My Documents>Class Materials>Eportfolio_Workshop-LFose>MS Word Docs. Click on the document titled Profile.doc document and open it.

2. We are going to copy/paste text from this document, but first we are going to convert it to a .txt document instead of a .doc document. We need to make this conversion because Microsoft Word places hidden code in its documents that can often cause problems on your html web page. Go to File > Save As… in Microsoft Word and when the Save As dialog box appears, go to the bottom of the dialog box where it says: Save as type: and select Plain Text from the pop-up menu. Add a .txt extension to the name so that the file is being saved as .txt and click the Save button. When the warning dialog box appears, make sure the radio button next to Windows Default is selected and click OK.

3. Now open the Profile.txt document and select all the text in the document by pressing Ctrl−A and then press Ctrl−C on your computer keyboard to copy the text to the clipboard.

4. Go back to your Dreamweaver file and place your cursor where you want the text on the page and press Ctrl−V to paste the text you copied from the .txt document.

5. Highlight all the text that you pasted into the Dreamweaver file and if needed, reformat the font by selecting Verdana, Arial, Helvetica from the Font menu in the Properties Inspector.

6. Go to File > Save As… and save the page. Then, preview the page in Internet Explorer. Here is a case where WYSIWYG may not always be exact so be sure to check it.

---

**Examining the HTML Code:**

Hand−coding a table is a tiresome task. In fact, tables are probably the most convenient feature of most WYSIWYG web page creation programs because it takes the pain out of the process. To prove this, click on the Code button and take a look at the HTML code for the table. Quite confusing, eh? This is why HTML editors like Dreamweaver are so popular! However, knowing how to examine this code can be helpful when editing a table or any other HTML code for that matter.

---

**Running an Accessibility Report**

To validate a site for accessibility, start by opening a page from the site you wish to evaluate and be sure that it has already been saved. (For the purpose of this tutorial, just keep the accomplishments.html page open).

1. Select Site>Reports and the Reports dialog box will appear (Figure 19).
2. If you wish to run a report on more than the current document, go to the pop-up menu next to Report On: and select Entire Current Local Site or you may even specify individual folders for evaluation. For the purpose of this tutorial, leave it set to Current Document.

3. Under the HTML Reports folder, select Accessibility and then click on the Report Settings… button.

4. The Accessibility dialog box appears (Figure 20), which allows you to select the standards used to evaluate a site (i.e., you may choose to validate based on Section 508 standards or the W3C guidelines, or examine only a single set of elements, such as images.) For example, if you would like to only evaluate your site according to Section 508 standards, first select the ALL category and click the Disable button. This will turn ALL reporting off. Then select the 508 accessibility category and click the Enable button. This will only activate rules pertaining to Section 508 standards. Click the Save button to save your choices for future reports.

5. Click on the OK button and Dreamweaver will return to the Reports dialog box. Click Run to create a report, which will be displayed in the Results panel (Figure 21).
6. Click on the Split button to split the window so you can view both Design view and Code view at the same time and then double-click on any line in the Results Panel. Dreamweaver will highlight the place in the code where that problem occurs and also select the property in the actual design view. **(Note:** Sometimes the FAILED results are actually valid code since some images may be a part of the design of the web page, i.e., a footer image that we wouldn’t want a screen reader to read to the user)**

7. The results are from both automatic and manual tests. The automatic tests look for obvious errors on the page, such as missing ALT tags. The manual tests require you to review the indicated content and consider such points, such as whether or not a long description is really necessary for an image. Failed automatic tests are indicated by a red X next to the item. Required manual tests are indicated by a gray question mark next to the item.

8. Each item listed in the Results panel cites the relevant rule according to Section 508 standards and W3C guidelines. If you need more information about a particular standard, click the More Info icon (Figure 22) in the Results panel to open the Reference panel.

![Figure 22: More Info Button](image)

9. The Reference panel provides explanations of the rules used and contains links to more detailed information about Section 508 standards and W3C guidelines so you can make a better decision about whether the error is valid.

10. After repairing a page, it’s wise to run the report again to verify that all problem issues have been resolved.

11. If you want to save the report and examine it more later, you may click on the Save Report icon (Figure 23) to the left of the Results panel. This opens the Save As... dialog box, which will allow you to name the report and save it as a .XML file to a location on your computer.

![Figure 23: Save Report Icon](image)

12. If you wish to close the report window, click on the Close Report icon (Figure 24) in the top-right corner of the Results panel and select Close Panel Group.

![Figure 24: Close Report Icon](image)
Placing Your Files on a Web Server

Eventually you will have to place your web site onto a web server so they can be viewed by the public. Here at Cal Poly, all faculty, staff and students are given web space within their Unix account. The name of the machine that houses the files is polylog1.calpoly.edu In order for your account to be able to display web pages, certain changes must first be made on that machine.

**Downloading Software To Upload Web Pages to UNIX Server**

1. Open your web browser and go to the following URL: [http://my.calpoly.edu](http://my.calpoly.edu)
2. Login to the Cal Poly Portal using your Cal Poly Username (Username is your email alias without the "@calpoly.edu") and Password (i.e., YOUR UNIX password).
3. Click on the Technology tab in the portal. If you don’t already have the Cal Poly Software Channel on your Cal Poly Portal page, click on the Subscribe link at the top right-corner.
4. Under Applications, click on “plus” sign next to the Cal Poly Software Channel.
5. Arrange the channels location on the page where you wish for it to be located and then click on the Finished button.
6. Return to the Cal Poly Portal page, click on the Technology tab again and find the Cal Poly Software Channel you just added and click on either the link for Windows software or the link for Mac software.
7. PC (Windows) users can use the Run command from the Start menu of their computers and skip this download software step (available in older versions of Windows) or will need to find the QVT/Term software and click on the Download link below it in order to download the software. Mac users will need to find the Better Telnet (OS 9) software and click on the Download link below it in order to download the software. (Note: For more information about the software or to get installation instructions, click on the link connected to the NAME of the software.)
8. After you have installed the proper software, follow the instructions given below to login to polylog1.calpoly.edu. **(NOTE: THERE ARE DIFFERENT INSTRUCTIONS BELOW DEPENDING UPON WHETHER YOU ARE A WINDOWS USER USING THE “RUN” COMMAND, A WINDOWS USER USING QVT/TERM, OR A MAC USER USING BETTER TELNET.)**

**Getting Your Account Ready Using Telnet (Windows) or Better Telnet (Mac OS 9) or TN3270 (Mac OS X):**

Your Cal Poly account must have a directory in it called public_html. All your web pages must go into this directory. IT IS THE ONLY DIRECTORY THAT WEB BROWSERS ARE ALLOWED TO ACCESS... and for good reason: Your mail is also stored in that account and sharing it with the world could lead to some dire consequences.
PC (Windows) Users

Running Telnet with “Run” Command

To get your account set up, we can use the RUN command to access Telnet.

1. From the Start menu in Windows, select Run (or open QV Term if it is on your machine and then open polylog1.calpoly.edu). If you chose Run, you will see the following dialog box. Type in exactly what is shown here in Figure 25: `telnet polylog1.calpoly.edu`

   ![Figure 25: Run Telnet Program](image)

2. Click on the OK button.
3. A new Telnet session will begin. What you are doing here is connecting to polylog1. You are no longer working on your local computer so you have to interact with polylog1 using UNIX commands. This means no point-and-click, no mouse movement; it is all command driven (YUCK!).
4. A new connection window will appear as shown in Figure 26 below:

   ![Figure 26: Telnet Login Window](image)
PC (Windows) Users
Using QVT/Term to Access Polylog1

Launch the QVT/Term software program. As the program launches, you will be prompted "Do you want to make QVT/Term your default Telnet application?" We recommend "Yes". From the File pull-down menu, select Open. Type a host name in the Host Name or IP Address field. Click on OK to connect.

Important: In order to connect using SSH2 -- whether servers are on or off-campus -- be sure to click on the radio button for SSH2. Examples of SSH2 required connections on Information Technology Services centrally-managed servers are in support of the Sun Instructional Lab and Projects Lab.

Note: The QVT/Term program has many configuration settings (e.g. colors, SSH2, printers, keyboard mappings, scripting files, backspace key). Users should refer to online help via the "Help" pull-down menu, their peers or instructors for settings specific to their account and printer needs.

Mac Users (OS 9)
Using Better Telnet to Access Polylog1

Launch the Better Telnet software program in OS 9. From the File pull-down menu, select Open Connection. In the Host Name or IP Address field, enter polylog1.calpoly.edu This is the standard interface for Cal Poly users to access Central Unix accounts. Click on OK to connect.

Note: The Better Telnet program has many configuration settings (e.g. colors, SSH, printers, keyboard mappings, scripting files, backspace key). Users should refer to online help via the "Help" pull-down menu, their peers or instructors, for settings specific to their account and printer needs.

Mac Users (OS X)
Using TN3270 3.1.1 for OS X

Download and install TN3270 3.1.1 for OS X from the Cal Poly portal (http://my.calpoly.edu) in the Technology tab > Software Channel > Mac area.

Open TN 3270 and select File > New Session. In the dialog box that appears, type polylog1.calpoly.edu for the Host Name. For the Window Title: type polylog1

A new connection window will appear. Follow the instructions below to login.
Logging In & Configuring Websetup

Now you will login to polylog1 and configure permissions to UNIX with the websetup command:

1. At the login prompt, type in your login (i.e., your alias) and then press the Enter key.
2. At the password prompt, type in your password (i.e., Unix password) and then press the Enter key.
3. At the terminal type, press the Enter key until you see a percentage (%) prompt. Your screen should look like Figure 27 below:

![Telnet Screen at Percentage Prompt](image)

4. At the % prompt, type websetup and then press the Enter key.
5. When websetup is done, check the text that was created to see if polylog1 noticed that you already have a folder called public_html. This websetup command will create a public_html folder for you if you don’t already have one.
6. At the % prompt, type cd public_html (this allows you to change directories) and press the Enter key.
7. At the % prompt, type mkdir eportfolio and press the Enter key. You have just created an eportfolio folder within your public_html directory.
8. Minimize the polylog1 window OR logout of Telnet for now by typing logout at the % prompt and press Enter.

A WORD ABOUT WEBSETUP

The simple rules to follow regarding the use of websetup:

Rule 1: Run websetup ONLY on personal accounts.
Rule 2: DO NOT run websetup on club or dept ulib accounts (see “A Closer Look” below).
Rule 3: Submit a Remedy ticket to CSA if a user deletes the public_html folder on a club or dept ulib account. Why? The websetup routine will not properly rebuild the public_html folder. Submit a Remedy ticket to CSA through the Single-Click Access section of the Cal Poly portal (or call the Service Desk at Ext. 6-7000) and request that "the public_html folder be rebuilt on the account."

The websetup routine was created primarily for use on personal Unix accounts. According to the documentation at http://www.calpoly.edu/~www/create.html the routine essentially performs the following steps:

1. Checks to see if a public_html folder exists. If not, it creates one with the correct permissions.
2. Recursively checks for folders under public_html and ensures that permissions are set correctly.
3. Recursively checks files under the public_html folder and ensures that permissions are set correctly.

A Closer Look:

1. It is never necessary to run websetup on club or dept ulib accounts. These accounts contain a properly configured public_html folder at the time of account creation. On these accounts ONLY, file permissions are correctly set when files are uploaded using FTP (WS-FTP, Dreamweaver, etc.) because the FTP program on Central UNIX correctly permits them. This is not the case for personal accounts.
2. What if a user deletes the public_html folder on a club or dept ulib account? Neither the user nor websetup can properly rebuild the folder. This must be done by CSA via a Remedy ticket. The path to the public_html folder on these accounts is configured differently than it is for personal accounts, which is why websetup doesn't repair the folder correctly if it's deleted (remember it was designed for use with personal accounts).
3. Personal Unix accounts need file and folder permissions to be set correctly by the user and websetup will set permissions.

**TRANSFERRING YOUR WEB PAGES TO THE NEW DIRECTORY:**

In order for your site to be seen on the World Wide Web, your files need to be uploaded to a live web server. In Dreamweaver, the files on your hard drive are referred to as local files and the files on a live web server are referred to as remote files. To access the FTP (remote) component of Dreamweaver, you must follow the steps below:

1. Select Site > Manage Sites... and the Manage Sites dialog box will appear.
2. In the Manage Sites dialog box, highlight the class_eportfolio site and click on the Edit button.
3. The Site Definition dialog box will open. Click in the left Category column on Remote Info as shown in Figure 28 below. From the Access pop-up menu, select FTP. For the FTP Host: type polylog1.calpoly.edu. For the Host Directory: type public_html. For Login: type your login name (i.e., your alias) and for Password: type your Unix password. Click on the checkboxes next to Save and Use Passive FTP as well.
4. In the Category column to the left, click on Site Map Layout and the Site Map Layout dialog box will appear (Figure 29).

5. Click on the gold folder next to Home Page: and navigate to your home page (i.e., your index.html file).

6. Click the OK button. Click Done in the Edit Sites dialog box to close it.

7. Back in the Files Panel Group on the Sites tab, click on the pull-down menu that says Local View and change it to Remote View.

8. Click on the Connect button (Figure 30). After some processing time, you should see the inside of your public_html folder from your polylog account appear in the Remote View of the Dreamweaver’s site window.
9. Click on the Expand/Collapse icon (Figure 31), which is located right below the Local View/Remote View pull-down menu.

10. Dreamweaver will open two windowpanes, which display the Local View on the right and the Remote View on the left.

11. **WARNING:** If you already have web pages located in your public_html folder on the Remote (server) side, **BE VERY CAREFUL IN THIS NEXT STEP.** You’ll want to make sure that if you have an index.html file in your public_html folder that you **DON’T OVERWRITE** it with the index.html file we have made in this tutorial. This is the reason you were instructed to create the eportfolio folder on the server beforehand so that you wouldn’t accidentally write over an index.html file that resides in your public_html folder, which may already be functioning for your own personal website.

12. **CAREFULLY** drag-select or Shift-select the files in the class_eportfolio folder from the Local View windowpane and then drag them over the eportfolio folder in the left Remote View windowpane. The files have now been copied to your polylog1 account and should be residing in the eportfolio folder on the Remote View side of Dreamweaver.

13. We’re almost done, but not quite! We still need to provide permission to the polylog server to display the files as explained in the next section.

**CHANGING PERMISSIONS ON YOUR FILES WITH TELNET:**

There is still one more thing you have to do before your files will be active for viewing. Even though you have moved your files over to polylog1, you still have to tell polylog1 that you want to give permission for these pages to be read from the web server (seems redundant, I know). Please follow the directions below:

1. Maximize the polylog1 window or open Telnet again (if you logged out and quit). If you need to, login and give your password as you did before and press **Enter** until you get the % prompt again.

2. At the % prompt, type **websetup** and then press the **Enter** key. This command will set the permissions so your files can be viewed.

3. At the % prompt, type **logout** and press the **Enter** key.

4. Quit Telnet.

5. Now your web pages should be readable from any browser.
Viewing Your Web Site on the Web

1. Open your browser (Netscape or Internet Explorer).
2. In the location box, type in the following URL:
   http://www.calpoly.edu/~lfose/eportfolio  (Except change the name “lfose” to your own alias name. Your alias in UNIX at Cal Poly is the first initial of your first name plus your last name, up to 8 letters total)
3. If everything went well, you should see your index.html page that was created in this tutorial.
4. The last step is to check all your links to make sure they really work!

Congratulations!

You now have an eportfolio!

Go celebrate!