Dreamweaver 102: Learning the Basics of MX 2004

ITS Technology & Learning Services
Dr. Luanne Fose
Revised July 30, 2004
# Table of Contents

- Learning the Basics of Dreamweaver MX 2004 ........................................ 1  
- Getting Familiar with the Layout .......................................................... 1  
- The Importance of Site Management ..................................................... 8  
- Managing Panels and Panel Groups ....................................................... 9  
- Implementing Cal Poly Web Page Templates ......................................... 12  
- Setting Preferences for Web Accessibility ............................................. 13  
- A Short Lesson on HTML Code ............................................................. 14  
- Setting the Page Properties .................................................................. 16  
- Working with the CP Template Web Pages ........................................... 19  
- Creating Relative Links for Navigation Bar .......................................... 22  
- Adding a Dynamic Date to Your Web Page .......................................... 23  
- Using Our Index.html Page as a Template .......................................... 24  
- Adding an Image to the Index.html Page .............................................. 24  
- Spell Check Your Page .......................................................................... 26  
- Preview the HTML Page in Your Browser............................................. 26  
- Copying/Pasting Text on the Biography Page ....................................... 30  
- Copying/Pasting Text on the History Page ........................................... 32  
- Adding a Table to the Favorites Page .................................................. 33  
- Embedding a Sound File on a Web Page .............................................. 35  
- Running an Accessibility Report ............................................................ 37  
- Placing Your Files on a Web Server ...................................................... 40  
- PC (Windows) Users Running Telnet with “Run” Command ............... 41  
- PC (Windows) Users Using QVT/Term To Access Polylog1 ............... 42  
- Mac Users (OS 9) Using Better Telnet To Access Polylog1 ............... 42  
- Logging in & Configuring Websetup .................................................... 42  
- Viewing Your Web Site on the Web ...................................................... 46
Learning the Basics of Dreamweaver MX 2004

Dreamweaver MX 2004 is one of the most powerful and popular HTML editing software programs on the market today. Creating a web page and managing your web site with Dreamweaver is much easier than you might imagine. This workshop will cover the basics you need to know to get started with an overview of the basic Dreamweaver features and tools:

Getting Familiar with the Layout of Dreamweaver MX 2004
The Importance of Site Management: Defining a Site
Downloading and Implementing Cal Poly Templates to Create Web Pages
Setting Preferences for Web Accessibility (Making Your Pages Section 508 Compliant)
Adding Keywords and Descriptions to Your Pages to Assist Search Engine Spiders
Creating Relative, Absolute, and Email Hyperlinks
Creating New Text Content or Importing Existing Text from Microsoft Word
Using Cascading Style Sheets (CSS) to Control Formatting
Adding a “Dynamic Date” to Automatically Update Every Time You Change a Page
Inserting Images and Tables
Running an Accessibility Report in Dreamweaver
Uploading Your Files to a Cal Poly Server for Availability on the World Wide Web

Getting Familiar with the Layout

THE WORKSPACE:

Let's open Dreamweaver and get started! From the Start menu, select Programs>Applications>Keyserver Applications> Macromedia Dreamweaver MX 2004.

When you open Dreamweaver MX 2004 the very first time on a PC, a dialog box will appear asking which environment you wish to work in (Figure 1): Designer workspace or Coder workspace. (Note: Mac users are NOT offered a choice of workspace; the workspace defaults to Designer workspace). The first layout option offered on the PC, Designer workspace, allows you to open several documents within the same window and Dreamweaver’s panels are organized into groups and docked on the right side of the Dreamweaver window. Coder workspace is a variation on the Designer workspace with the panels docked on the left side of the Dreamweaver window. When you first open documents in the Coder workspace, you are presented with the code of the document instead of the view that reflects what the page will look like when viewed with a browser (i.e., Designer workspace). For the purpose of this tutorial, select the Designer workspace radio button and click OK. If in the future you become more comfortable with working with code and prefer viewing the HTML code for your document as the first view of a page, you may change this setting by going to Edit>Preferences (Ctrl+U) and selecting the General category. Within the General category, click on the Change Workspace… button and the dialog box will appear again, allowing you to change your workspace choice. (Note: On a Mac, Preferences are found under the Dreamweaver MX 2004 menu at the top left of the screen.)
THE START PAGE:

After you have chosen your workspace configuration, Dreamweaver MX 2004 will open with the **Start Page** showing (Figure 2). If you’re new to Dreamweaver, the Start Page can be useful since it gives you quick access to tutorials and a tour of the key features. It also gives you immediate access to more recently opened files and one-click creation for static or dynamic pages.

If the Start Page seems to be in your way and you don’t want it opening every time you open Dreamweaver, you can turn it off by going to **Edit>Preferences>General** and turning off the checkmark under **Document options**: where it says “Show start page” and click **OK**.
On the Start Page, click on the HTML link under where it says Create New. This will open a new HTML page to work with. When Dreamweaver MX 2004 opens a new HTML document, it opens with the main window called the Document Window (Figure 3) and several panels and palettes appear as well. If you have opened Dreamweaver before, the panels will be placed exactly where they were the last time you quit the program. Panels and palettes that have been closed previously may be accessed from the Windows menu within Dreamweaver.

**THE DOCUMENT WINDOW:**

The Document Window is the main center of activity in Dreamweaver. Since Dreamweaver considers itself to be a WYSIWYG (What You See Is What You Get) HTML tool, the Document Window will give you a clear idea of what you can expect to see in the web browser window when you are done (although not exactly).

![Figure 3: Document Window](image-url)
LET'S EXAMINE THE DOCUMENT WINDOW:

- The **Title Bar** displays the filename and the title of the current web page.
- The **Body** of the HTML document is displayed in the main viewing area of the Document window.
- The **Status Bar** at the bottom of the Document Window indicates three important properties of the document:

1. The **Tag Selector**: This displays all the HTML tags that apply to the current selection.
2. The **Window Size** indicator: This displays the current size of the Document Window (e.g., 760 X 420). The Window Size is an important parameter for determining how the final web page will be displayed on different sized monitors. The numbers in the Window Size indicator will change if you resize the Document Window so you should NEVER change the size of the window by dragging on the lower right-hand corner as you would in other applications. Instead, you should use the Window Size indicator to set a pre-set window size by clicking on the arrow, which will display a pop-up window of choices. 760 X420 (800 X 600) maximized is a good compromise to meet the needs of both large and small monitors of your intended audience. (Note: You will NOT be able to make a choice from the Window Size indicator if your page has been maximized. If the choices are greyed out in the WIndow Size indicator, click on the **Restore** icon in the upper right of your HTML page and then try again.)
3. The **Download Status** area displays the total size (in kilobytes) of the current page and the amount of time it would take to download on a 56k modem. If you want to see how long it would take to download at a different speed, you can go to **Edit>Preferences** and select the **Status Bar** category (Figure 4) and from the pull-down menu next to **Connection speed**, select a different speed (e.g., 1500 Kilobits per second). For the purpose of this tutorial, leave the connection speed set for 56k.

![Figure 4: Status Bar Preferences](image)
**THE PROPERTIES INSPECTOR:**

The two most important properties to have turned on are the Properties Inspector (Figure 5) and the Insert Bar. From the Window menu, make sure there are checkmarks next to these two items.

![Figure 5: The Properties Inspector](image)

The Properties Inspector is context-sensitive. This means that it will constantly change its appearance depending upon what type of element has been selected in the Document Window. The Properties Inspector controls many important settings, including settings for Text, Tables, Alignment, Images, and Media and you will spend a great deal of time using it to format your pages.

**THE INSERT BAR:**

The Insert Bar has been slightly changed in Dreamweaver MX 2004. It now displays a pull-down menu of choices rather than using tabs as it did in Dreamweaver MX. The Common menu in the Insert bar allows you to insert the most commonly used objects and is the default menu option. To select other options, click on the pull-down menu next to Common and choose from Layout, Forms, Text, HTML, Application, Flash elements, and Favorites.

![Figure 6: Insert Bar with Common Menu in Dreamweaver MX 2004](image)

If you prefer, you can change the Insert Bar to display the tab views as it did in Dreamweaver MX. To change to tab view, select Show as Tabs from the Common pull-down menu. If you change your mind and want to return to the pull-down menu appearance default, right-click on the area where the tab views appear and select Show as Menu.

As you move your mouse over the various icons in the Insert Bar, Dreamweaver will tell you the name of the tool.
ICONS RESIDING IN THE COMMON MENU:

- **Hyperlink Link**: Insert hypertext links at the insertion point, or immediately following the current selection.

- **Email Link**: Inserts an email link. This tool is especially useful to have someone contacted on your web page.

- **Named Anchor**: This tool places a named anchor at the insertion point. Anchors are great for navigational purposes since it lets you link (jump) to a specific point on a page instead of requiring that someone scroll down to get there.

- **Table**: This tool places a table at the insertion point and brings up a dialog box asking you for specific details.

- **Image**: This icon is different than in Dreamweaver MX since it has an arrow with a submenu attached to it. Within the submenu you can select from the following:
  
  - **Image**: Inserts an image at the insertion point. A dialog box appears so that you can select an image file.
  
  - **Image Placeholder**: Inserts an image placeholder at the insertion point. This is great for when you don't have the image ready yet but want to reserve a place for it in your layout. A dialog box allows you to specify a name and dimensions for the placeholder where you can later place your image.
  
  - **Rollover Image**: This choice prompts you to specify two image files (an “on” and an “off” image) that are used to define a rollover. A rollover is an image that changes when the mouse moves across it.
  
  - **Fireworks HTML**: This choice places an HTML file produced by Fireworks at the insertion point.
  
  - **Navigation Bar**: Inserts a set of images to be used for navigating through a web site. The Navigation Bar usually consists of four images for each button that represent a different user action of the button such as Up, Over, Down, and Over While Down.

- **Media**: This option contains buttons for inserting animated or interactive media objects such as Flash, Flash Buttons, Flash Text, Java applets, Parameters, ActiveX objects, and Plugins (e.g., QuickTime movies).

- **Date**: This option places the current date at the insertion point. A dialog box appears in which you can specify a format for the date and indicate whether Dreamweaver should update the date automatically every time you save the file making it dynamic.
• **Comment:** This option places a comment in the HTML code at the insertion point. If you’re in Design view, a dialog box appears where you can enter text for the comment. To view the comment, look at the page in *Split* or *Code* view. Comments are an excellent way to keep track of special things you did in the code that you might not remember when you are looking at the code at a later date. Comments do not show up in the browser or Design view of the document.

• **Templates:** This option allows you to insert editable, optional, and repeating regions in template files that you wish to use over and over.

• **Tag Chooser:** This option allows you to choose a tag to insert, from a hierarchical tree of categorized tags.

Other tabs besides **Common** in the Insert Bar include **Layout**, **Forms**, **Text**, **HTML**, **Application**, **Flash Elements**, and **Favorites**. Below are short explanations of these other menu choices:

- The **Layout** menu allows you to insert tables and layers, and lets you choose between two views of tables: Standard (default) view and Layout view.

- The **Forms** menu contains buttons for creating forms and inserting form elements.

- The **Text** menu allows you to insert a variety of text- and list-formatting tags, such as `b`, `em`, `p`, `h1`, and `ul`.

- The **HTML** menu allows you to insert a Horizontal Rule or add Head tags such as `Meta`, `Keywords`, or `Descriptions`.

- The **Application** menu allows you to insert dynamic elements such as recordsets, repeated regions, and record insertion and update forms.

- The **Flash Elements** menu allows you to work with Flash movies that can be configured in Dreamweaver. After a Flash element is added, its attributes are available in the Tag Inspector for personalization. Dreamweaver MX 2004 ships with one Flash element called **Image Viewer** which enables designers to easily create slide shows with a variety of animated transitions.

- The **Favorites** menu allows you to configure your own Insert Bar according to your own specifications. You are presented with the **Customize Favorite Objects** dialog box from which you can choose the objects you wish to include in your own favorites Insert Bar. Objects can be grouped through the use of a dotted-line separator.
The Importance of Site Management

File management is one of the biggest challenges of building a web site. Web sites require the creation of many documents and their properties all at once due to numerous text and image files. Organization, folder structure, and consistent naming conventions of all the pages and graphics are a very important part of building a web site.

In addition, the fact that most people build web sites from their hard drive and then upload the files to a web server when they finish just compounds the organizational problem! For example, if you created content in folders on your hard drive and called the folders “HTML” and “Images,” you would need to replicate this EXACT folder structure when you uploaded the files to your web server or the links to your files would be broken.

Dreamweaver has created a site–management scheme that helps alleviate this problem by requiring that you keep all your files within one main “root” folder so that you can easily duplicate the folder structure that is on your hard drive when you upload the folders to a web server. A root folder is not any different from any other kind of folder on your hard drive except that you have specified to Dreamweaver that all your web development will take place within that folder. The advantage of this system is that if you decide at a later time to change the folder hierarchy of your site by adding a folder or changing a folder name, these changes can be made easily. If you were to hand–code the pages instead and decided to make changes mid–stream, it would be quite a painful process to check all the links and file names (I know first hand... I did it once!) Dreamweaver can make this process painless as long as you choose to work within its site-management scheme.

DEFINING A SITE – THE KEY TO SUCCESS

You will be working with a folder containing HTML and image files called “mx2004_website” that has already been placed in the My Documents folder on the Desktop of your computer in the Training lab. The path to this folder is My Documents>Class Materials>Dreamweaver MX 102–LFose>mxwebsite.

1. From the Site menu at the top of Dreamweaver, select Manage Sites… Dreamweaver will open the Manage Sites window. Click on the New button and from the submenu, select Site. Dreamweaver defaults to opening the Site Definition window with the Basic tab selected. The Basic tab will take you through a series of questions (a sort of wizard) to help you create the settings for your site definition. For the purposes of this tutorial, click on the Advanced tab to bypass this.

2. With the Advanced tab selected, make sure that Local Info is highlighted in the Category area on the left of this window. For the Site Name:, type “mx2004_website” (Note: For Local Info this is an internal naming convention so you can use any kind of name you wish without worrying about whether or not to use spaces or capitalization)

3. Click on the small yellow folder icon to the right of the Local Root Folder: text box. Navigate to the mx2004_website folder that is in the My Documents folder on the Desktop of your computer. (Remember the exact path is My Documents>Class Materials>Dreamweaver MX 102–LFose>mx2004_website) Click on the mx2004_website folder once and click the Open button; then click on the Select button. Note: DO NOT highlight
the images folder before clicking on Select. (Mac users: Simply click on the folder once and click Choose)

4. Click in the checkbox next to Refresh Local File List Automatically. Also click on the checkbox next to Cache: Enable Cache. This will increase the speed with which Dreamweaver performs its link-management features.

5. Click on the small yellow folder icon next to Default Images Folder: and take the same path as before but this time add the images folder to the entire path (i.e., My Documents>Class Materials>Dreamweaver MX 102–LFose>mx2004_website>images) Click on the images folder once and click the Open button; then click on the Select button.

6. Click OK at the bottom of the dialog box to save your site definition and when the Manage Sites dialog box appears, click Done.

Congratulations! You have just set up your first Dreamweaver site! When you later open the Files Panel Group, your setup should look something like the illustration in Figure 7 below.

![Figure 7: Files Panel Group View](image)

### Managing Panels and Panel Groups

Dreamweaver MX 2004 has retained the earlier layout of Dreamweaver MX, which introduced the use of panel groups and panel tabs (Figure 8). Each panel group can be expanded or collapsed, and can be docked or undocked with other panel groups. If you wish to customize your panel groups, it will make it easier to access the panels you need without cluttering your workspace. Panels within a panel group appear as tabs.
To expand or collapse a panel group, do one of the following:

- Click on the expander arrow on the left side of the panel group’s title bar

**OR**

- Click on the panel group’s title.

Let’s look at a few of the more important Panel Groups and Panels:

**THE FILES PANEL:**

You will probably find that you access this the Files Panel Group the most. The Files Panel Group allows you to define a site, manage the local files in your site, upload and download files from a remote site, and browse the files on your local disk outside of your site. With the Files Panel you can make a local site on your hard drive that’s just like the directory structure site on your web server so that everything exports to the server smoothly. If you don’t see the Files Panel, go to Windows>Files (F8).

**THE ASSETS PANEL:**

The Assets Panel tab (within the Files Panel Group) displays the elements, such as images or movie files that you are using in building your page or site. You can obtain assets from various sources. For example, you might create assets in an application such as Macromedia Fireworks, Adobe Photoshop, or Macromedia Flash, receive them from a co-worker or client, copy them from a clip-art CD, or download an image from a graphics web site. You can use the Assets Panel in two ways: as an easily accessible list of the assets in your site or as a way to organize the assets that you use most frequently by using the Favorites list. The Assets Panel tab automatically puts your site’s assets in the list when the Site radio button is selected. You may add whatever assets you wish to the Favorites list for easy access by highlighting the assets you wish to add and then clicking on the Add to Favorites button at the bottom right-corner of this panel. You can view the assets in your Favorites List by clicking on the radio button next to Favorites.
**The History Panel:**

You may want to add the History Panel Group to the list of panels on the right of the screen in order to access its “undo” features. To add the History Panel Group, select Window > History (Shift+F10). The History Panel will show you a list of the steps you’ve performed in the active document since you created or opened that document, up to a specified maximum number of steps. (Note: The History panel doesn’t show steps you’ve performed in other frames, in other Document Windows, or in the Files Panel.) It allows you to undo one or more steps; it also allows you to replay steps and to create new commands to automate repetitive tasks. The slider in the History Panel initially points to the last step that you performed. One of the great things about the History Panel is that even after you have saved the document before viewing it in your browser, you can undo your steps in the History Panel as long as you don’t close the document. Once you close the document, the steps in the History Panel will be gone.

**To undo the last step in the History Panel:**

Drag the History Panel slider up one step in the list. This has the same effect as choosing Edit > Undo. The undone step will turn gray.

To undo multiple steps at once, do one of the following:

- Drag the slider to point to any step
- OR
- Click to the left of a step along the path of the slider; the slider scrolls automatically to that step, undoing steps as it scrolls.

As with undoing a single step, if you undo a series of steps and then do something new in the document, you can no longer redo the undone steps; they will disappear from the History Panel.

**To change the number of steps that the History panel retains and shows:**

1. Choose Edit > Preferences > General.
2. Enter a number for Maximum Number of History Steps (default is 50).

The default value should be sufficient for most users’ needs. Be aware that the higher the number, the more memory the History Panel requires. This can greatly affect computer processing performance and significantly slow down your computer. When the History Panel reaches this maximum number of steps that have been set in Preferences, the earliest steps are discarded from the panel.
Implementing Cal Poly Web Page Templates

The Cal Poly Web Authoring Resource Center (WARC) provides developers of Cal Poly official web sites with the information and tools necessary to plan and build a site that meets basic requirements for university identity, web accessibility, usability, and aesthetics. In addition, the WARC provides valuable information on how best to maintain web sites for currency and efficiency. Check out the WARC web site by opening a browser (Internet Explorer or Netscape) and navigating to the following URL: http://www.calpoly.edu/warc/

On the WARC website, you will find a section allowing you to download university templates. The path to the templates page is University ID > Templates from the above URL or directly http://www.calpoly.edu/warc/universityid/templates.html. By using the university templates, you are establishing your web pages as an "official" part of the Cal Poly University web site. The templates have been designed to be consistent with and complimentary to the recent redesign of the Cal Poly home page and its top-tier subsections (i.e., Students, Faculty & Staff, Prospective Students, etc.). The templates conform to the university’s “Minimum Page Requirements” for web pages and were specifically designed for easy navigation and eye-pleasing appearance after surveys and meetings with campus focus groups. They have also been designed with usability and web accessibility in mind. You can easily "personalize" them to reflect your department or group and each layout has been created to provide substantial "free" space for extensive customization within the body of each template. We believe that it's important that Cal Poly web pages reflect standards of quality and professionalism appropriate to showcase the university as what it is -- one of the nation’s best -- and implementing the templates will assist you in this task.

Let's Download the Templates and Place Them Within Dreamweaver:

1. Go to http://www.calpoly.edu/warc/universityid/templates.html
2. Click on the “Download Now” link at the top of this page. This will take you to http://www.calpoly.edu/warc/universityid/templates/download.html
3. Under the section labeled “Cal Poly Template download,” navigate to the area that applies to your operating system (PC or Mac) and click on the appropriate link.
4. Since we are using PCs in this tutorial, click on “cp_template_v1.1.zip – (PC)” to download it to the Desktop of your computer.
5. When the File Download dialog box appears (Figure 9), click on the Save button.

Figure 9: File Download Dialog Box

Dr. Luanne Eris Fose
Revised July 30, 2004
6. When the Save As dialog box appears, save the file to the following folder in the My Documents folder: My Documents>Class Material>Dreamweaver MX 102-LFose> A .zip file will be placed in your Dreamweaver MX 102-LFose folder. Use a utility such as Stuffit Expander, WinZip, or Power Archiver to unzip the file. (Note: Mac users will need to use Stuffit Expander to unstuff the .sit file). If you are using a Cal Poly license for the Power Archiver utility, double-click on the file and when the Power Archiver new window pops up, choose Action > Extract... In the "Extract to:" area, browse to My Documents>Class Materials>Dreamweaver MX 102-LFose and click the Extract button.

7. You should now have a folder called cp_template unzipped in your Dreamweaver MX 102-LFose folder.

8. Right-click on the cp_template_v1.1.zip and select Delete to delete the zipped folder.

9. Double-click on the cp_template folder to open it. Right-click on the cp_template.html file and select Copy from the menu. Navigate to the My Documents>Class Materials>Dreamweaver MX 102-LFose>mx2004_website folder. Right-click and paste the cp_template.html file into that location.

10. Now move the images from the cp_template folder to our mx2004_website images folder. Navigate to the My Documents>Class Materials>Dreamweaver MX 102-LFose>cp_template>images folder and select everything (Ctrl-A or Shift-Click) in this images folder (including the image folders of footer, header, menubreadcrum) and then right-click your mouse and select Copy.

11. Navigate to the My Documents>Class Materials>Dreamweaver MX 102-LFose>mx2004_website>images folder and open the folder. Right-click in the folder with your mouse and select Paste to move the necessary Cal Poly images to this folder.

12. Now when you look in your Files Panel Group within Dreamweaver, you should see the cp_template.html file as well as additional images and images folders within your mx2004_website images folder.

---

**Setting Preferences for Web Accessibility**

Similar to Dreamweaver MX of the past, Dreamweaver MX 2004 allows you to set your preferences so that you will be reminded to follow the 508 federal accessibility guidelines as you insert images, tables, forms, and other media into your web page.

**To Turn on Accessibility Preferences:**

1. Go to the Edit >Preferences (Ctrl-U).
2. In the **Category** column at the left side of this dialog box, click on **Accessibility**.

3. Click all the checkmarks under **Show Attributes when Inserting**: (i.e., **Form Objects**, **Frames**, **Media**, **Images**). (Note: Unlike Dreamweaver MX, you will no longer turn on accessibility options for Tables; these options have been improved and automatically incorporated into the Tables dialog box now.)

4. Make sure that **Offscreen Rendering (Disable when using Screen Readers)** is also selected.

5. Click **OK**.

6. Now when you insert an image, form objects, or media, Dreamweaver will bring up the appropriate dialog boxes to remind you to insert the proper Alt tags, etc., that are needed to make your web pages accessible to everyone.

---

**A Short Lesson on HTML Code**

An HTML page is a set of instructions (tags) suggesting to your browser how to display the enclosed text and images. The browser knows what kind of page it is handling based on the tag that opens the page (e.g., `<html>`) and the tag that closes the page (e.g., `</html>`). The great majority of HTML tags come in pairs, in which the closing tag always has a forward slash before the keyword (e.g., `<p>` and `</p>`) A few important tags may be represented by a single element tag such as the image tag `<img>`.

An HTML page is divided into two primary sections: the `<head>` and the `<body>`. Information relating to the entire document goes in the `<head>` section: the title, description, keywords, and any language subroutines called from within the `<body>`. The content of the web page is found in the `<body>` section. All the text, graphics, embedded animations, Java applets, and other elements of the page are found between the opening `<body>` and closing `<body>` tags.
Summary information about the content of a page is conveyed through <head> tags that reside within the <head> section of your web page. Two important <head> tags you might want to be aware of are **Keyword** objects and **Description** objects. By inserting keywords on your web page, you can assist search engines spiders in categorizing your page and have a huge impact on the accessibility of your page. Although the title of your web page that fits into the browser title bar also affects how your page is categorized with search engine spiders, the Keyword and Description tags have an unlimited amount of room, allowing you to expound on the content of your web page. However, avoid the temptation to stuff these head tags repeatedly with the same word. The search engines are engineered to reject too many instances of the same words and your description will not get the attention it deserves. The content that you place in your **Description** box will be the description that will appear next to your link on the search engine’s page of findings. For this box, you should use sentences that clearly describe what your web page is about.

**TO ADD KEYWORDS TO YOUR WEB PAGE:**

1. Open a web page within Dreamweaver (for the purpose of this tutorial, double-click on the page called `cp_template.html` in the Files Panel Group to open it.)
2. Select **Insert > HTML > Head Tags > Keywords**
3. When the **Keywords** dialog box appears, type appropriate keywords for your webpage in lowercase with commas between them (e.g., homer simpson, cal poly, the simpsons)
4. Click **OK**.
5. If you click on the **Code** button, you can see the keywords listed in the head section of the HTML code as `<meta name="keywords" content="homer simpson, Cal Poly, the simpsons">` This is the code the search engine spiders need to categorize your page and find it when someone searches for your page.

**TO ADD A DESCRIPTION TO YOUR WEB PAGE:**

1. With the same `cp_template.html` page open, select **Insert > HTML > Head Tags > Description**.
2. When the **Description** dialog box appears, type a description of your web page in sentence form with proper capitalization and punctuation.
3. Click **OK** to close the dialog box.
4. If you click on the **Code** button, you can see the description listed in the head section of the HTML code as something like this: `<meta name="description" content="This is the home page for Homer Simpson's faculty web page at Cal Poly. Homer Simpson is currently a tenured Materials Engineering Professor at Cal Poly; however, he is best known for his antics on Fox Networks television show The Simpsons that was created by Matt Groening."">` This is the text that will appear as the description of your web page when a search engine lists it.
Setting the Page Properties

When you first open a new page in Dreamweaver, your default web page is untitled, with no background image and only a plain, white background. You can change any of these properties (and more) with Dreamweaver’s Page Properties dialog box. In Dreamweaver MX, the Page Properties were set to use HTML tags to set up the text and link colors, the background color or background image, and the page title. These value were automatically placed within the <body> tag. Dreamweaver MX 2004 promotes the use of Cascading Style Sheets (CSS), which is quickly becoming the standard in the industry. CSS uses internal or external “style sheets” which affect the properties settings of an entire page (internal) or an entire web site (external). For the purpose of this tutorial, we are going to create an internal CSS within Dreamweaver and then export it and attach it to all our pages in our web site in order to create an external CSS that effects all our pages. Using CSS is the most efficient method to work with web sites. Once you use it, you will see why so many people are turning to this method of managing the style of their web page content.

1. Before we get started setting the Page Properties, let’s make that sure that the default for using CSS hasn’t been turned off. Go to Edit > Preferences > General and make sure that under Editing options: there is a checkmark next to “Use CSS instead of HTML tags” and then click OK. (Note: If in the future, you wish to use HTML tags instead of CSS, you would want to turn this option off.)

2. With the cp_template.html file still open, choose Modify > Page Properties (Ctrl-J) or click on the Page Properties button that is in the Properties Inspector (Note: This button is new to Dreamweaver MX 2004). The following dialog box will appear:

![Page Properties dialog box](image)

---

**Figure 11: Page Properties with CSS Turned On**
1. With Appearance selected in the Category list on the left of this dialog box, click on the pull-down arrow next to where it says Page font: and select the font list of Verdana, Arial Helvetica, sans-serif. This will now be the font list that all of your text will default to unless you change it manually. Notice that in designing web pages you don’t select just one font but rather you provide Dreamweaver with a “font list.” The font list has your first-choice font listed first; if the viewer of your web page doesn’t have that font, it will load the next font choice that you have provided in your font list. If you wish to make your own font list, click on the pull-down menu next to Page font: and select Edit Font List…

![Edit Font List Dialog Box](image)

Figure 12: Edit Font List Dialog Box

2. When the Edit Font List dialog box appears (Figure 12), find Tahoma in the Available Fonts: box and click on the left arrow to add it to the Chosen Fonts: box. Continue to do this adding Verdana, Arial, and sans serif. You will see them added in the Font List: box at the top of this dialog box. Click OK to confirm this font list. Now back in the Page Properties dialog box, if you select the pull-down menu next to Page font: you will see your new font list of Tahoma, Verdana, Arial, and sans-serif added to the list. For the purpose of this tutorial, keep your font choice as Verdana, Arial, Helvetica.

3. By using CSS, we can select our font size to be displayed in a variety of ways (i.e., pixels, points, inches, centimeters, millimeters, picas, etc.). Next to the Size: text box, select 12 from the pull-down arrows and select pixels from the pull-down menu next to it. (Note: You can also type in the number of the size if you prefer.)

4. Next to Text color: click on the little color palette box and select a black of #000000 to be the default for your pages or simply type the hexadecimal code of #000000 in the text box.

5. Type the hexadecimal number #A1B39C in the text box next to Background color. This color has been selected as the default background color for the Cal Poly template. If you wanted to change this color, you could click on the color palette next to the word Background color: and select a color from the web-safe color palette. (We will discuss hexadecimal numbers and what they mean in terms of web-safe colors later.)
6. The **Background Image** area allows you to browse for a different background image if you wish to use one that you have created previously with a program such as Adobe Photoshop or Macromedia Fireworks. We won’t be using a background image in this tutorial so you can just ignore it for now.

7. Set all the **Margins** to 0 pixels.

8. Now in the **Category** list of this dialog box, click on **Links** so that we can set the default link properties.

9. Where it says **Link font**: let it stay at the default of *(Same as page font).*

10. For the **Size**: select 12 pixels.

11. Set the **Link color**: at #003300 (This is a dark green that matches some of the other images on the Cal Poly template).

12. Set the **Visited links**: to be a blue color (hexadecimal #243A97). This will cause the links to from green to blue if someone has already visited a particular link.

13. Set the **Rollover link**: to be a gold color (hexadecimal #CC9900) This will cause the link to change to gold when the viewer places the mouse over the link.

14. Set the **Active link**: to be the same green as the link color: #003300. This is the color that the link changes to briefly when the user selects a link. In this case, there would be no change; it would remain green.

15. Next to the **Underline style**: select **Always underline**.

16. For now, we are going to skip working with the **Headings**. But this is where you could set the font for all headings, the sizes, bold, italic, and color of the various headings (tags <h1>– <h6>) if you desired.

17. Now in the **Category** list of this dialog box, select **Title/Encoding**.

18. In the text box next to **Title**: type “**Homer J. Simpson – Cal Poly State University**” This will appear as the title for this page in the web browser. Note: You can also change a document’s title in the Document Window by clicking in the **Title** field and pressing **Enter**.

19. In the text box next to **Encoding**, make sure that it says **Western (European)** which is the default.

20. Click on the **Apply** button and then click **OK** to close the **Page Properties** dialog box.

21. Now, if you click on the **Design Panel Group** and select the **CSS Styles** tab, you will see that several CSS styles have been set for you. You can either edit them from this area or re–open **Modify > Page Properties** to edit them.

---

**A WORD ABOUT WEB–SAFE COLORS:**

What is a web–safe or browser–safe color? Web–safe colors are the 216 colors supported by browsers across different platforms (Mac and Windows). If you use the browser–safe colors inside the Page Properties setting, you reduce the risk of having your colors look differently than you intended them to when people view your web pages on different platforms and browsers. In HTML, colors are expressed either as hexadecimal values (e.g., #FF0000) or as color names (e.g., red, black, blue, etc.). All the colors in the color palettes used in Dreamweaver are web–safe and in fact, any hexadecimal value that combines the pairs 00, 33, 66, 99, CC, or FF represents a web–safe color. You can use the eyedropper to select from these colors in the palette. Go to [http://www.lynda.com/hexh.html](http://www.lynda.com/hexh.html) to view a web–safe colors chart with hexadecimal and RGB references.
**SAVING YOUR WORK:**

Before we make any more changes to the page, let’s save the file with a new name - we are going to call it index.html. A web page with this name has special significance. Most web servers recognize the index.html page as the default home page of a site. If you type the URL [http://www.calpoly.edu](http://www.calpoly.edu), for example, what you will really see is the index.html page for the Cal Poly web site, even though you did not type the URL that way. The web server knows to open the index.html file automatically without requiring that the full URL be typed in which would actually be [http://www.calpoly.edu/index.html](http://www.calpoly.edu/index.html). This routine is a standard on all UNIX-based servers and many web administrators (even though they use Windows-based servers), change their settings to incorporate index.html as the default home page. Therefore, if you name the opening page of your web site with the file name index.html, the web server will automatically open this file and you will save people from having to type a longer URL.

You should periodically save your work as you are working on a web page to make sure that nothing happens to it (e.g., power outage, software or hardware crash, etc.). Save your work right now by selecting **Save As** from the **File** menu and let’s rename the file and call it **index.html**. Check the location to make sure it is being saved to the proper folder (i.e., **My Documents>Class Materials>Dreamweaver MX 102–LFose>mx2004_website**) and then click on the **Save** button. In the future when you wish to save the file, you can always just select **Save** from the **File** menu (or **Ctrl-S**) since you have named the file and selected a location; however, to be sure that it is truly being saved, using the **Save As** command is a safer way to save. The next time you use the **Save As** command and click the **Save** button, Dreamweaver will ask if you want to overwrite the file; when this happens, click **Yes**.

---

**Working with the CP Template Web Pages**

Let’s change some of the text on the Cal Poly template that we have saved as **index.html**:

1. Your **index.html** page should be open since you just saved it with that name, but if it isn’t, double-click on **index.html** in the **Files Panel Group**.
2. Highlight the text for “**Department Name**” at the top-right area of the web page and press the **Backspace** key to delete it.
3. Type “**Homer J. Simpson**”.
4. Go to the bottom-right area of the web page and change the Department Name to the “**Materials Engineering Department**.”
5. Change the phone number from **805.756.XXXX** to **805.756.7360**.
6. Click on the text where it says **email@calpoly.edu** and change it to say **hsimpson@calpoly.edu**
7. Now, let’s change the email link itself. Highlight the entire link and then look at the address given in the Properties Inspector (Figure 13) where it says: **Link**.
8. Unlike other links, an email link always has the words **mailto:** in front of the actual email address. Change the link to say: **mailto:hsimpson@calpoly.edu**
9. Next, while the text is still highlighted, you can click on the **Bold (B)** button in the Properties Inspector to make the email text stand out a bit better.

10. The font color is already chosen because of the choices that were made in the **Page Properties** dialog box earlier. However, you can change the color of individual text selections by highlighting the text and clicking on the **Text Color Palette** next to the **Size** box. A color palette will appear with web-safe colors to select from. Notice also that if you drag your mouse outside of the color palette, the pointer changes to an eyedropper and a hexadecimal number appears in the color palette title bar. You can select colors from images to have the image colors correspond more closely to the text colors in your site. Although we are using black as the text color for our site, let’s change the text for **Last Update** to **red** (hexadecimal #FF0000) so that you can see how easily text color can be changed from the default. Highlight the words **Late Update** and click on the **Color Palette** and select the **red** color (i.e., hexadecimal #FF0000) to change the text color for these words to red.

**RESIZING THE DOCUMENT WINDOW:**

The **Document Window** status bar displays the window’s current dimensions in pixels. If you click this window size, Dreamweaver displays the **Window Size** pop-up menu, which lets you set the window size to fit any of several common monitor sizes. To design a page that looks its best at a specific size, you can adjust the Document Window to any of the predetermined sizes, edit those predetermined sizes, or create new sizes.

**Let’s choose a predetermined size for the Document Window:**
1. Click on the arrow on the Windows pop-up menu at the bottom of the Document Window to reveal the predetermined choices (Figure 15). For our index.html document, make sure that 760 X 420 is selected, which is the optimum size for an 800 X 600 monitor – the normal size of the general population’s monitor these days. The window size given reflects the inside dimensions of the browser window, without borders; the monitor size is listed in parentheses.

2. **Note:** If Dreamweaver will not allow you to select a different size in the Windows pop-up menu (i.e., the selections are greyed out), click on the Restore (i.e. Maximize) button for that particular page and then you should be able to select the 760 X 420 size.

![Figure 15: Set Window Size](image)

**EDITING THE NAVIGATION BAR:**

The Cal Poly web page template has a navigation bar on the left side of the page to assist the viewer in navigating to the other pages in the web site. Let’s edit it to reflect our pages:

1. Place the cursor at the end of the text in the navigation bar that says Sample Link 1. Use the Backspace key to delete this text. Type: “Biography” to replace it and then highlight the text and press the Bold button in the Properties Inspector to bold the text.

2. Place the cursor at the end of the text in the navigation bar that says Sample Link 2. Use the Backspace key to delete this text. Type: “History” to replace it and **Bold** this text.

3. Place the cursor at the end of the text in the navigation bar that says Sample Link 3 this **is an example of how link text wraps.** Use the Backspace key to delete this text. Type: “Favorite Things” to replace it and **Bold** this text.

4. Because Sample Link 3 was an example of wrapping text, we need to go into the HTML code to remove the wrap. Click on the Split button (Figure 16) to show both the Design and Code view simultaneously.

![Figure 16: Split Button](image)
5. Because our cursor resides in the area where the Sample Link 3 text previously resided, the cursor goes to this exact location in the code when we view it in Split View. After the words “Favorite Things” in the code you will see code that says \(<</font>$$</TD>$$</TR>\). Highlight the $$</TR>$$ code and press the Backspace key to erase it until the cursor is placed right after the $$</TD>$$ code. Removing the $$</TR>$$ will remove the extra row of the wrap. Click on the Design button (Figure 17) to return to Design View and view the table with the extra row removed.

Figure 17: Design Button

6. Place the cursor at the end of the text in the navigation bar that says Sample Link 4. Use the Backspace key to delete this text. Type: “Accomplishments” to replace it and Bold this text.

7. Place the cursor at the end of the text in the navigation bar that says Sample Link 5. Use the Backspace key to delete this text. Type: “Official Web Site” to replace it and Bold this text.

8. Delete the text for Sample Link 6 and Sample Link 7 since we aren’t going to use these in our navigation bar and delete the 4-dot bullet next to these as well. (Simply place your mouse in the cell of the bullet and press the Backspace key twice.)

9. Go to the bottom of the index.html page and change the text for the Sample Link 1 through Sample Link 5 to reflect the same navigation: Biography, History, Favorite Things, Accomplishments, and Official Web Site. Delete Sample Link 6 and Sample Link 7 here as well.

---

## Creating Relative Links for Navigation Bar

The ability to link to other pages and sites is what makes the web dynamic. Besides email links, which we have already made, there are two other types of links: relative and absolute. Relative links will take you to another page within your own web site; absolute links will take you to an outside web site on the World Wide Web.

We will start by adding relative links to our navigation bar text:

1. Highlight the text “Biography” in the left navigation bar. Go to the Link box in the Properties Inspector and type “bio.html.” This is the name that we will give to the Biography web page when we create it later on.

2. Continue in this manner, highlighting text in the navigation bar for History, Favorite Things, and Accomplishments creating the following links respectively: history_complete.html, favorites.html, accomplishments.html.

3. Create the same links for the navigation of Biography, History, Favorite Things, and Accomplishments at the bottom of the web page as well.
4. Go to the text at the top of the page where it says “Department Name Home” and delete the text “Department Name” and replace it with “Homer J. Simpson – Home”. (Note: If you can’t see the text, click on the first table tag in the tag selector.) Highlight the Homer J. Simpson Home text at the top of the page and then go to the Link box in the Properties Inspector and type “index.html”. This will allow the user to always return to the Homer Simpson Home page from wherever they might be.

**Now we will add an absolute link to a web site on the World Wide Web:**

1. Open Internet Explorer and find the web site you wish to have your viewers link to. Type the URL: [http://www.thesimpsons.com](http://www.thesimpsons.com) This should take you to the official Fox web site for the Simpson show. Highlight the URL so it is completely selected and press Control–C to copy it to the Clipboard. Close Internet Explorer.
2. Return to your index.html page and highlight the text “Official Web Site” in the left navigation bar. Place your cursor in the Link box of the Properties Inspector and press Control–V to paste the URL. By using this method of going to the web site first in your browser, you will eliminate the possibility of having a dead link because you made a typo or spelling error.
3. Now place the same link on the text where it says Official Web Site at the bottom of the web page.

---

**Adding a Dynamic Date to Your Web Page**

If you add a dynamic date to your web page, it not only allows the viewers to know when the page was last updated, it also updates the date automatically anytime you save the web page.

1. Navigate to the bottom of the page where it says “Last Update” and erase the text “mm/dd/yy”.
2. From the Insert Bar, select the Common tab and then select the Date icon.
3. The Insert Date dialog box will appear (Figure 18). Select the Day, Date and Time Format that you desire and then place a checkmark in the box next to Update Automatically on Save. Click the OK button and a date will be added as you requested. Every time you save the web page, the date will automatically be updated.

![Figure 18: Insert Date Dialog Box](image-url)
Using Our Index.html Page as a Template

Now that we have our index.html almost completed and have the navigation bar and links set, we can save this page out to use as a template for our other web pages.

1. First, remove the text that says “Place page content here” and remove the text that says “Open the instructions.html file”.
2. Go to the File menu and select Save As... Save this page as index.html.
3. Now go to the File menu and select Save As... again. Now save the page as bio.html.
4. Continue to do this two more times, saving the page as history.html and favorites.html. You should see these four pages (index.html, bio.html, history.html and favorites.html) added to your Files Panel Group on the right of the Dreamweaver screen.
5. If you saved the pages with the new names in the order described above, the page you are currently working on has been renamed “favorites.html”. Close this page by going to File > Close.

Adding an Image to the Index.html Page

Let’s finish off our home page (index.html) by adding an image to it.

1. Double–click on index.html in the Files Panel Group to open it again.
2. Highlight the text “Page Title” and delete it. Also delete the 4–dot bullet before and after it.
3. In the Properties Inspector, click on the Align Center button. This is to place our cursor in the middle of the page in order to add an image there.
4. Press Enter once to make a paragraph return and get the cursor lower on the page.
5. From the Insert menu, select Image (Control–Alt–I) and then the Select Image Source dialog box will appear (Figure 19). Navigate to the homer_claymation.jpg image (i.e., My Documents>Class Materials>Dreamweaver MX 102–LFose>mx2004_website>images) and click once on the image. You will see an Image Preview to the right in this dialog box. If the claymation image of Homer Simpson appears, click on the OK button to insert it.
6. Since we set the preferences earlier to remind us to abide by web accessibility rules, the Image Tag Accessibility Attributes dialog box will appear (Figure 20). Where it says Alternate Text:, type “Homer Simpson”. This will allow the screen reader to skip the image and continue reading the page while it allows the user to know there was an image of Homer Simpson in that location on the web page.

Note: If the image you inserted was primarily for page design (e.g., a header or footer image) and not important for a screen reader to read to a blind or visually-impaired user, you would ignore the Alternate Text: text box and simply click the OK button. Then later in the Properties Inspector, you should select the pop-up menu next to Alt and select <empty>. This will place quotation marks next to the Alt tag in the code (e.g., alt=""), which will not be read by the screen reader. When you run a Dreamweaver Accessibility Report on a Cal Poly template (discussed later on in this tutorial) you will find many empty Alt tags, which have been done this way so that they are ignored by a screen reader.
7. If the image of Homer Simpson isn’t already selected, click on it to select it. This changes the Properties Inspector to show the attributes for the image. Go to the Link box and type the link “bio.html”. This creates a link to the image so that when a person clicks on the image, it links directly to the Biography web page.

8. In the text box next to Border, in the Properties Inspector, type 15 and then press Enter. This adds a border of 15 pixels to the image. Since a link has been attached to this image, the border color is set at the color that was set for links in the Page Properties. In the Dreamweaver Document Window it looks like the color for the border will be blue, but when you look at this page in the browser, the style is applied with a green border that turns gold (i.e. the selected rollover link color) when the mouse is placed upon it.

9. Click your mouse below the horizontal link under Homer’s image and press the Align Center button in the Properties Inspector. Type the following text: Homer J. Simpson – “Professor Extraordinaire” and then highlight it.

10. From the Format menu in the Properties Inspector, select Heading 3. This will enlarge and bold the text when you view it in your browser.

11. Go to File > Save As… and save your index.html page.

---

**Spell Check Your Page**

You should always spell check your work before you place it on the web.

1. To spell check, go to the Text menu at the top of the Dreamweaver screen and select Check Spelling (Shift+F7). Do a normal spell check throughout the document, clicking the Ignore button for words that you intend to keep as they were typed.

2. Go File > Save As… and save your index.html page.

---

**Preview the HTML Page in Your Browser**

Whenever you are working on an HTML page, you should preview it in your browser to see how it will really look on the web. Preview your Home page by following the steps below:

1. From Dreamweaver’s File menu, select Preview in Browser… and from the submenu, select the browser you wish to view it in (e.g., Internet Explorer or Netscape). Dreamweaver MX 2004 also allows you to preview in a browser by simply clicking on the globe icon at the top of your page and selecting Preview in (name of browser).

2. It will take a few moments as your computer opens the browser you selected and displays a temporary file to view in the browser. It is good practice to always view your web page in both Internet Explorer and Netscape because sometimes the pages will appear slightly different depending upon the browser and previewing them can help you decide upon a compromise on your original web page to get the look you desire in both browsers. This is also where you should test all your links to make sure they work when
you are finished with your other web pages.

3. Notice that rollovers have been applied to the links in the navigation bar. Rollovers for the navigation bar are included within the Cal Poly template. For more information on creating rollovers, take the TLS Dreamweaver Rollovers course.

4. Minimize the browser and return to your Home page in Dreamweaver. Make any changes you think you need to make to the page, check it again by previewing it in the browser and then save the page one more time within Dreamweaver.

**CONFIGURING DREAMWEAVER TO USE OTHER BROWSERS:**

1. If you need to configure Dreamweaver to preview in another browser, return to Dreamweaver and select **File>Preview in Browser>Edit Browser List...** and the Preview in Browser dialog box will open (Figure 21).

![Figure 21: Edit Browser Lists Dialog Box](image1)

4. Click on the “+” sign in this dialog box next to the word **Browsers**:

5. When the **Add Browsers** dialog box appears (Figure 22), type a name for the browser, click the **Browse...** button next to **Application:** to find the browser application on your computer, and click the checkbox next to **Primary Browser** or **Secondary Browser**, depending upon which default you wish it to have.

![Figure 22: Add Browser to Preview Browser List](image2)
6. Notice that when you go to File > Preview in Browser now, you have the choice of Internet Explorer (F12) or Netscape (Control-F12). You can continue to set up other browsers for previewing in this manner (e.g., Macintosh users may wish to set up a preview choice for the Safari browser, which has become quite popular in the Mac community). F12 and Control-F12 are two commands that are worth memorizing since by using them you can preview your pages without navigating to the File menu first or without having to click on the globe icon.

**CREATING AN EXTERNAL CASCADING STYLE SHEET (CSS)**

Since Dreamweaver MX 2004 defaults to using internal cascading style sheets (providing a list of all the rules for a single page in CSS), we might as well take advantage of this feature by changing the internal cascading style sheet (CSS) into an external CSS. An external style sheet is a file containing the CSS rules, which links to one or more web pages. The biggest advantage of using an external style sheet is that you can customize and change the appearance of an entire web site from just one file! For example, let’s say you decided that you wanted to change the color of your body text in every one of your web pages. Make the change in your external style sheet and attach it to the web pages you want it to effect and “walah,” it will effect every page automatically. Follow the instructions below to export the styles and re-attach them to pages:

1. First, let’s click on the Code button and scroll near the top of the page. Note that the code for internal style sheets appears in the head tag area starting with the code text that says something like: `<style type="text/css"... and ends with the </style> tag. This is referred to as an “embedded” or “internal” style sheet and this style of CSS can only be used within this one page. However, we can export this information to act as an "external style sheet" and then relink it to affect several pages at once within a web site.

2. To export this style information, go to File>Export>CSS Styles... and navigate to the root folder of your web site. Save the file in the root folder with a name that makes sense to you and make sure that you add a .css extension to the file name (e.g., simpsonstyles.css).

3. Note: When you export the code it does not remove the style from the page, you must do this manually. To remove the internal style sheet, go to Design Panels>CSS Styles. Highlight <style> and click on the little Trash icon or right-click on <style> and select Delete. The CSS internal style code will be removed from the page.

4. To attach the exported external style sheet, go to the CSS tab, click on the first icon that says Attach Style Sheet. This will open the Attach External Style Sheet dialog box (Figure 23).
5. Click the **Browse** button. This will open the **Select Style Sheet File** dialog box (Figure 24). Browse for the style sheet you saved in the root folder of **mx2004_website** (i.e., **simpsonstyles.css**) and click once on the file to highlight and select it. Make sure that this dialog box has selected the file as a document relative link by making sure that **Document** is the selection next to **Relative to:** and click on the **OK** button to close this dialog box.
6. When you are returned to the **Attach External Style Sheet** dialog box, make sure that **Add as: Link** is selected and then click **OK**.

7. Now you are returned to the document. If you click on the **Code** button and look at the `<head>` tag now, you will see that it says something like: `<link href="simpsonstyles.css" rel="stylesheet" type="text/css">`, which clearly shows that it is linked to the external style sheet.

8. Since we’re finished with the home page (i.e., **index.html**) for now, make sure it is saved by selecting **File>Save As…** and then close the page by selecting **File > Close**.

9. Open the other pages that we created previously (i.e., **index.html**, **bio.html**, **history.html** and **favorites.html**) and delete the internal styles within them by going through the same process; then attach the external style sheet to each one of these files so that they will all have the same look and feel stylewise.

---

**Copying/Pasting Text on the Biography Page**

Now let’s work on the Biography page by copying/pasting text from a Microsoft Word document:

1. Since we have already created a template for the Biography page by saving the **index.html** page with the new name "bio.html," we don’t have to repeat a lot of our previous efforts setting up the links and formatting. Go to the **Files** panel at the right of the Dreamweaver screen and double-click on **bio.html** to open the page.

2. Choose **Modify>Page Properties** (**Ctrl-J**), click on **Title/Encoding** in the **Category** column and change the **Title:** to **Homer J. Simpson – Biography**. Click the **Apply** button and then click **OK**. This will place the correct title on this page when it is viewed by the web browser.

3. In the right frame of the html page, erase the text that says "Page Title" and replace with "Homer J. Simpson: Biography".

4. Open Microsoft Word, go to **File > Open…** and navigate to the following folder: **My Documents>Class Materials>Dreamweaver MX 102-LFose>Simpson Word Docs**. Click on the document titled **Homer Simpson Biography.doc** document and open it.

5. We are going to copy/paste text from this document, but first we are going to convert it to a `.txt` document instead of a `.doc` document. We need to make this conversion because Microsoft Word places hidden code in its documents that can often cause problems on your html web page. Go to **File > Save As…** in Microsoft Word and when the **Save As** dialog box appears, go to the bottom of the dialog box where it says: **Save as type:** and select **Plain Text** from the pop-up menu. Add a `.txt` extension to the name so that the file is being saved as **Homer Simpson Biography.txt** and click the **Save** button. When the warning dialog box appears, make sure the radio button next to **Windows Default** is selected and click **OK**.

6. Now select all the text in the **Homer Simpson Biography.txt** document below the text **Homer J. Simpson: Biography** and press **Ctrl-C** on your computer keyboard to copy it to the clipboard.

7. Minimize the `.txt` document and return to Dreamweaver MX 2004. Place your cursor below the horizontal line that resides below the text **Homer J. Simpson: Biography** and
8. Highlight all the text in this right frame window (including the Homer J. Simpson: Biography text) and if needed, reformat the font by selecting Verdana, Arial, Helvetica from the Font menu in the Properties Inspector.

9. With all the text still highlighted, click on the Text Indent button (Figure 25) in the Properties Inspector to indent the text a bit.

Figure 25: Text Indent Button

10. Line up your cursor right before the text “Life Roles” and press Enter to cause a paragraph break. This will help us with the next task of creating bullets.

11. Select all the text below the horizontal line (starting with “Life Roles” and ending with “Maggie”) so that it is highlighted and click on the Unordered Lists button (Figure 26) to place bullets next to the main points of this text. Delete any extra bullets that might have occurred due to unintended paragraph returns in the code.

Figure 26: Unordered Lists Button

12. Select the text “Life Roles” and click on the Bold button in the Properties Inspector to make it stand out more. Do the same with the text “Education” and “Personal Life.”

13. Place your cursor below all of this text and press Enter. Click on the Unordered Lists Button to turn it off and get rid of the extra bullet that appeared when you pressed Enter.

14. From the Insert menu, select Image and navigate to the image called simpsonfamilycolor.jpg (Figure 27); select it and click OK.

15. Provide the alternate text tag of “Simpson Family Portrait” and click OK.

16. Click on the Simpson Family image and click on the Align Center button in the Properties Inspector.
17. Go to File > Save As... and save the page. Then, preview the page in Internet Explorer. Here is a case where WYSIWYG isn’t exact. You will notice that that is not a space between the lines of the unordered list. Minimize your browser, return to Dreamweaver and place an additional Shift–Enter between each of the bullets. Save the file again and return to preview it in Internet Explorer. Now, you have the proper spacing that we intended.

---

**Copying/Pasting Text on the History Page**

The History page has been completed for you to save time and we have linked all the History links to this completed page named `history_complete.html`.

If you have time, you might try completing it on your own by copy/pasting text from the document called `Homer Simpson History.txt` that resides in the `Homer Simpson Word Documents` folder.

Here are some of the things you will need to remember as you try this page on your own:

1. Modify the Page Properties (Ctrl–J) and change the Title: to The Simpsons – History. Click the Apply button and then click OK. This will place the correct title on this page when it is viewed by the web browser.
2. Copy/paste the text from the Homer Simpson History.txt document.
3. Reformat the font of the text to Verdana, Arial, Helvetica
4. Reformat the paragraph returns in the text to resemble the original .txt document.
5. Create a link to the URL displayed in the reference and change the format of this reference text to Heading 5.
6. Insert the image titled `mattgroening_bw.jpg` and add an Alternative Text Tag that says “Matt Groening”.
7. Create an 8 pixel border for the Matt Groening image.
8. Add a caption to the image that says: Matt Groening – Creator of “The Simpsons” and format this text to Heading 6.
9. Save the file as `history_complete.html` so that our other history links are directed to it.
Adding a Table to the Favorites Page

Let’s add a table to the Favorites page to organize some text:

1. Go to the Files panel at the right of the Dreamweaver screen and double-click on the favorites.html page to open it.
2. Choose Modify>Page Properties (Ctrl-J), select Title/Encoding in the Category column and change the Title: to Homer J. Simpson – Favorite Things. Click the Apply button and then click OK. This will place the title on this page when it is viewed by the web browser.
3. Change the Page Title text in the right frame of the page to read: “Favorite Things”.
4. Position the cursor below the horizontal bar and press Shift-Enter to cause a line break before the insertion of a table.
5. From the Insert menu, select Table (Ctrl-Alt-T) and the Insert Table dialog box will appear. Enter the values as shown in Figure 28 below (Rows: 3, Columns: 3, Table Width: 65 Percent, Border: 2, Cell Padding: 0 and Cell Spacing: 5).

![Insert Table](https://example.com/figure28.png)

Figure 28: Insert Table
**Note:** Cell padding is the amount of space between the content of a layout cell and the cell wall and Cell Spacing is the amount of space between each layout cell.

6. Where it says **Header**, select **Top**. **Note:** This Header attribute does not display in the browser window. It is used primarily by screen readers, assistive software programs for the blind or visually impaired. This option applies scope tags to each cell of the top row of the table. The scope tags will make any information that you place in the cells of that top row act as identifiers for each of the cells in their respective columns. In plain English this means that when we type “Food” in the top cell of the first column, the remaining cells vertically below that column will be prefaced verbally by the word “Food” in order to indicate the content of those cells to a visually impaired person.

7. Under the section labeled **Accessibility**, type a caption for the table: **Homer Simpson's Favorite Things**. Select **Align caption: top** and then type a **Summary** such as **This is a table summarizing Homer Simpson's favorite things in life**. This summary will be read by the screen reader.

8. Click on the **OK** button to save your settings and display the table.

9. Click on the table that has been inserted to select it and then go to the status bar and select the **last** table tag. From the **Align** menu in the Properties Inspector, select **Center** to center the table in the frame.

10. In the top three cells of the first row, type the following respectively: **Food**  **Beverages**  **Sayings**

11. In the second row cells, type **Doughnuts**  **Duff Beer**  **Doh**!

12. Select all the cells and press the **Align Center** button in the Properties Inspector to align the text (and images) in the center of the cells.

12. Change the font of these cells to **Verdana, Arial, Helvetica** and click on the **Bold** button.

13. Select the first row of text all the way across and change the text color to **red** (#FF0000).

14. Select all the cells in the entire table and then go to the **Bg Color** palette in the Properties Inspector and select the color **green** (#003300). This will change the table background to green but the border outline will be white.

15. Select the second row of text all the way across and change the text color to **white** (#FFFFFF); this will allow you to see this text better on the green background.

16. In the bottom row, insert the images of **homer_donut.jpg**, **homer_beer.jpg**, and **homer_doh.jpg** (NOT **homer_doh2.jpg** which is for later) in the cells under the proper columns. Be sure to assign alternative text tags for each image (e.g., **Homer Eating Doughnuts**, **Homer Drinking Duff Beer**, **Homer Saying Doh**).

17. Go to **File > Save As…** and save the web page as **favorites.html**
EXAMINING THE HTML CODE:

Hand-coding a table is a tiresome task. In fact, tables are probably the most convenient feature of most WYSIWYG web page creation programs because it takes the pain out of the process. To prove this, click on the Code button and take a look at the HTML code for the table. Quite confusing, eh? This is why HTML editors like Dreamweaver are so popular! However, knowing how to examine this code can be helpful when editing a table or any other HTML code for that matter.

Embedding a Sound File on a Web Page

There are several different ways you can place a sound file on a web page with Dreamweaver. Dreamweaver will accept .mid (MIDI), .wav (Windows Audio), .aiff (Audio Interchange File Format), .MP3, .mov (QuickTime), and .ra or .ram (Real Audio) files. Although there is a simple method of just adding a link to an audio file, embedding an audio file gives you more control with option of a player that the viewer uses to interact with the audio.

Let’s embed an audio file on the accomplishments.html web page:

1. Go to your Files panel on the right of the Dreamweaver screen and double-click on accomplishments.html to open the page.
2. This page has already been completed for you for the most part except for the addition of the sound file. Scroll to the bottom of the page and line up your cursor in the space between the image of Homer Simpson and the text "Homer Simpson’s 32 Doh’s".
3. Go to the Insert bar and select Common from the pull-down menu if it isn’t already selected. Click on Media > Plugin.
4. When the Select File dialog box appears (Figure 29), navigate to audio>32dohs.wav, select the file and click on the OK button.

![Figure 29: Select File Dialog Box](image)

Dr. Luanne Eris Fose
Revised July 30, 2004
5. A plugin icon will be placed on the web page at the location you specified. With the plugin icon selected, go to the Properties Inspector below (Figure 31) and insert the following values:

- **W = 245 and H = 25.** This is the width and height of the player controls.
- **Src = audio/32dohs.wav** (this is the path to the .wav file and should already be there since you selected it in the Select File dialog box)
- **Align = Middle**
- **Plg URL = http://www.apple.com/quicktime** If the person doesn’t have a plugin installed on their computer that will play the audio file, the web page will direct the viewer to go to this URL to download and install QuickTime.

![Properties](image)

**Figure 30: Plugin Properties**

6. Click on the **Parameters...** button in the Properties Inspector to open the **Parameters** dialog box (Figure 31). We are now going to set a few parameters to control how the sound file is played.

![Parameters](image)

**Figure 31: Parameters Dialog Box**

7. Click on the “+” button and under the **Parameter** column, type **AUTOPLAY** and under the **Value** column, type false. By doing this we are telling it to not play the file automatically when the web page appears but to wait until the viewer clicks on the Play button.

8. Click on the “+” button again and under the **Parameter** column, type **CONTROLLER** and under the **Value** column, type true. This tells Dreamweaver to play a controller where the plugin icon is for the viewer to use. Click **OK** to close the **Parameters** dialog box.
9. You can try playing it with the Play button in the Properties Inspector but this often doesn’t work because it is dependent upon a default that Dreamweaver has that may be different than the configuration of your computer. The best way to test the sound is to preview it in your browser. Go to File>Preview in Browser>iexplore and click on the Play button in the controller that appears below the image of Homer Simpson.

10. Go to File>Save As... and save the file.

Running an Accessibility Report

To validate a site for accessibility, start by opening a page from the site you wish to evaluate and be sure that it has already been saved. (For the purpose of this tutorial, just keep the accomplishments.html page open).

1. Select Site>Reports and the Reports dialog box will appear (Figure 32).

![Figure 32: Reports Dialog Box](image)

2. If you wish to run a report on more than the current document, go to the pop-up menu next to Report On: and select Entire Current Local Site or you may even specify individual folders for evaluation. For the purpose of this tutorial, leave it set to Current Document.

3. Under the HTML Reports folder, select Accessibility and then click on the Report Settings... button.

4. The Accessibility dialog box appears (Figure 33), which allows you to select the standards used to evaluate a site (i.e., you may choose to validate based on Section 508 standards or the W3C guidelines, or examine only a single set of elements, such as images.) For example, if you would like to only evaluate your site according to Section 508 standards, first select the ALL category and click the Disable button. This will turn ALL reporting off. Then select the 508 accessibility category and click the Enable button.
button. This will only activate rules pertaining to Section 508 standards. Click the **Save**
button to save your choices for future reports.

![Accessibility Dialog Box](image)

**Figure 33: Accessibility Dialog Box**

5. Click on the **OK** button and Dreamweaver will return to the **Reports** dialog box. Click
**Run** to create a report, which will be displayed in the Results panel (Figure 34).

![Accessibility Report](image)

**Figure 34: Accessibility Report**

6. Click on the **Split** button to split the window so you can view both Design view and Code
view at the same time and then double-click on any line in the Results Panel.
Dreamweaver will highlight the place in the code where that problem occurs and also
select the property in the actual design view. *(Note: Sometimes the **FAILED** results are
actually valid code since some images may be a part of the design of the web page, i.e.,
a footer image that we wouldn’t want a screen reader to read to the user)*

7. The results are from both automatic and manual tests. The automatic tests look for
obvious errors on the page, such as missing ALT tags. The manual tests require you to
review the indicated content and consider such points, such as whether or not a long
description is really necessary for an image. Failed automatic tests are indicated by a
red X next to the item. Required manual tests are indicated by a gray question mark
next to the item.
Each item listed in the Results panel cites the relevant rule according to Section 508 standards and W3C guidelines. If you need more information about a particular standard, click the More Info icon (Figure 35) in the Results panel to open the Reference panel.

Figure 35: More Info Button

The Reference panel provides explanations of the rules used and contains links to more detailed information about Section 508 standards and W3C guidelines so you can make a better decision about whether the error is valid.

After repairing a page, it’s wise to run the report again to verify that all problem issues have been resolved.

8. If you want to save the report and examine it more later, you may click on the Save Report icon (Figure 36) to the left of the Results panel. This opens the Save As… dialog box, which will allow you to name the report and save it as a .XML file to a location on your computer.

Figure 36: Save Report Icon

9. If you wish to close the report window, click on the Close Report icon (Figure 37) in the top–right corner of the Results panel and select Close Panel Group.

Figure 37: Close Report Icon
Placing Your Files on a Web Server

Eventually you will have to place your web site onto a web server so they can be viewed by the public. Here at Cal Poly, all faculty, staff and students are given web space within their Unix account. The name of the machine that houses the files is polylog1.calpoly.edu. In order for your account to be able to display web pages, certain changes must first be made on that machine.

**DOWNLOADING SOFTWARE TO UPLOAD WEB PAGES TO UNIX SERVER**

1. Open your web browser and go to the following URL: [http://my.calpoly.edu](http://my.calpoly.edu)
2. Login to the Cal Poly Portal using your Cal Poly Username (Username is your email alias without the "@calpoly.edu") and Password (i.e., YOUR UNIX password).
3. Click on the Technology tab in the portal. If you don’t already have the Cal Poly Software Channel on your Cal Poly Portal page, click on the Subscribe link at the top right-corner.
4. Under Applications, click on “plus” sign next to the Cal Poly Software Channel.
5. Arrange the channels location on the page where you wish for it to be located and then click on the Finished button.
6. Return to the Cal Poly Portal page, click on the Technology tab again and find the Cal Poly Software Channel you just added and click on either the link for Windows software or the link for Mac software.
7. PC (Windows) users can use the Run command from the Start menu of their computers and skip this download software step (available in older versions of Windows) or will need to find the QVT/Term software and click on the Download link below it in order to download the software. Mac users will need to find the Better Telnet (OS 9) software and click on the Download link below it in order to download the software. (Note: For more information about the software or to get installation instructions, click on the link connected to the NAME of the software.)
8. After you have installed the proper software, follow the instructions given below to login to polylog1.calpoly.edu. (Note: There are different instructions below depending upon whether you are a Windows user using the “Run” command, a Windows user using QVT/Term, or a Mac user using Better Telnet.)

**GETTING YOUR ACCOUNT READY USING TELNET (WINDOWS) OR BETTER TELNET (MAC):**

Your Cal Poly account must have a directory in it called public_html. All your web pages must go into this directory. It is the only directory that web browsers are allowed to access… and for good reason: Your mail is also stored in that account and sharing it with the world could lead to some dire consequences.
PC (Windows) Users
Running Telnet with “Run” Command

To get your account set up, we can use the RUN command to access Telnet.

1. From the Start menu in Windows, select Run (or open QV Term if it is on your machine and then open polylog1.calpoly.edu). If you chose Run, you will see the following dialog box. Type in exactly what is shown here in Figure 38: telnet polylog1.calpoly.edu

![Figure 38: Run Telnet Program](image)

2. Click on the OK button.
3. A new Telnet session will begin. What you are doing here is connecting to polylog1. You are no longer working on your local computer so you have to interact with polylog1 using UNIX commands. This means no point-and-click, no mouse movement; it is all command driven (YUCK!).
4. A new connection window will appear as shown in Figure 39 below:

![Figure 39: Telnet Login Window](image)
PC (Windows) Users
Using QVT/Term to Access Polylog1

1. Launch the QVT/Term software program. As the program launches, you will be prompted "Do you want to make QVT/Term your default Telnet application?" We recommend "Yes". From the File pull-down menu, select Open. Type a host name in the Host Name or IP Address field. Click on OK to connect.

2. Important: In order to connect using SSH2 -- whether servers are on or off-campus -- be sure to click on the radio button for SSH2. Examples of SSH2 required connections on Information Technology Services centrally-managed servers are in support of the Sun Instructional Lab and Projects Lab.

3. Note: The QVT/Term program has many configuration settings (e.g. colors, SSH2, printers, keyboard mappings, scripting files, backspace key). Users should refer to online help via the "Help" pull-down menu, their peers or instructors for settings specific to their account and printer needs.

Mac Users (OS 9)
Using Better Telnet to Access Polylog1

1. Launch the Better Telnet software program in OS 9. From the File pull-down menu, select Open Connection. In the Host Name or IP Address field, enter polylog1.calpoly.edu This is the standard interface for Cal Poly users to access Central Unix accounts. Click on OK to connect.

Note: The Better Telnet program has many configuration settings (e.g. colors, SSH, printers, keyboard mappings, scripting files, backspace key). Users should refer to online help via the "Help" pull-down menu, their peers or instructors, for settings specific to their account and printer needs.

Logging In & Configuring Websetup

Now you will login to polylog1 and configure permissions to UNIX with the websetup command:

1. At the login prompt, type in your login (i.e., your alias) and then press the Enter key.
2. At the password prompt, type in your password (i.e., Unix password) and then press the Enter key.
3. At the terminal type, press the Enter key until you see a percentage (%) prompt. Your screen should look like Figure 40 below:
4. At the % prompt, type websetup and then press the Enter key.

5. When websetup is done, check the text that was created to see if polylog1 noticed that you already have a folder called public_html. This websetup command will create a public_html folder for you if you don’t already have one.

6. At the % prompt, type cd public_html (this allows you to change directories) and press the Enter key.

7. At the % prompt, type mkdir mx2004_website and press the Enter key. You have just created a mx2004_website folder within your public_html directory.

8. Minimize the polylog1 window OR logout of Telnet for now by typing logout at the % prompt and press Enter.

**TRANSFERRING YOUR WEB PAGES TO THE NEW DIRECTORY:**

In order for your site to be seen on the World Wide Web, your files need to be uploaded to a live web server. In Dreamweaver, the files on your hard drive are referred to as local files and the files on a live web server are referred to as remote files. To access the FTP (remote) component of Dreamweaver, you must follow the steps below:

1. Select Site > Manage Sites... and the Manage Sites dialog box will appear.

2. In the Manage Sites dialog box, highlight the mx2004_website site and click on the Edit button.

3. The Site Definition dialog box will open. Click in the left Category column on Remote Info as shown in Figure 41 below. From the Access pop-up menu, select FTP. For the FTP Host: type polylog1.calpoly.edu. For the Host Directory: type public_html. For Login: type your login name (i.e., your alias) and for Password: type your Unix password. Click on the checkboxes next to Save and Use Passive FTP as well.
4. In the Category column to the left, click on **Site Map Layout** and the **Site Map Layout** dialog box will appear (Figure 42).

5. Click on the gold folder next to **Home Page**: and navigate to your home page (i.e., your `index.html` file).

6. Click the **OK** button. Click **Done** in the **Edit Sites** dialog box to close it.

7. Back in the **Files Panel** Group on the **Sites** tab, click on the pull-down menu that says **Local View** and change it to **Remote View**.
8. Click on the **Connect** button (Figure 43). After some processing time, you should see the inside of your public_html folder from your polylog account appear in the Remote View of the Dreamweaver's site window.

![Figure 43: Connect Button](image)

9. Click on the **Expand/Collapse** icon (Figure 44), which is located right below the **Local View/Remote View** pull-down menu.

![Figure 44: Expand/Collapse Icon](image)

10. Dreamweaver will open two windowpanes, which display the **Local View** on the right and the **Remote View** on the left.

11. **WARNING:** If you already have web pages located in your public_html folder on the Remote (server) side, **BE VERY CAREFUL IN THIS NEXT STEP.** You’ll want to make sure that if you have an index.html file in your public_html folder that you **DON'T OVERWRITE** it with the index.html file we have made in this tutorial. This is the reason you were instructed to create the **mx2004_website folder** on the server beforehand so that you wouldn’t accidentally write over an index.html file that resides in your public_html folder, which may already be functioning for your own personal website.

12. **CAREFULLY drag-select** or **Shift-select** the files in the **mx2004_website folder** from the **Local View** windowpane and then drag them over the **mx2004_website folder** in the left **Remote View** windowpane. The files have now been copied to your polylog1 account and should be residing in the **mx2004_website folder** on the Remote View side of Dreamweaver.

13. We’re almost done, but not quite! We still need to provide permission to the polylog server to display the files as explained in the next section.

**CHANGING PERMISSIONS ON YOUR FILES WITH TELNET:**

There is still one more thing you have to do before your files will be active for viewing. Even though you have moved your files over to polylog1, you still have to tell polylog1 that you want to give permission for these pages to be read from the web server (seems redundant, I know). Please follow the directions below:

1. Maximize the polylog1 window or open Telnet again (if you logged out and quit). If you need to, login and give your password as you did before and press **Enter** until you get the % prompt again.
2. At the % prompt, type `websetup` and then press the **Enter** key. This command will set the permissions so your files can be viewed.
3. At the % prompt, type `logout` and press the **Enter** key.
4. Quit Telnet.
5. Now your web pages should be readable from any browser.
Viewing Your Web Site on the Web

1. Open your browser (Netscape or Internet Explorer).

2. In the location box, type in the following URL:
   http://www.calpoly.edu/~lfose/mx2004_website (Except change the name “lfose” to
   your own alias name. Your alias in UNIX at Cal Poly is the first initial of your first name
   plus your last name, up to 8 letters total)

3. If everything went well, you should see your index.html page that was created in this
   tutorial.

4. The last step is to check all your links to make sure they really work!

Congratulations!
You now have functional web pages!
Go celebrate!